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Installing Info-Explorer
The steps below apply to Info-Explorer Lite as well as the Full and Writeback edition.

Next Steps: 6

NEXT STEPS: 
Getting Started Steps on page 14

Refer to Info-Explorer Training Guide for further details

Installing Info-Explorer
Info Explorer is installed by executing the EXE program downloaded from the Info-
Explorer website.

Use the following link: https://www.info-explorer.com/resources/downloads

InstallShield will execute and guide you through the installation steps.

Re-installations over-write existing installations on the target directory.

Note: You can change the default installation directory by clicking on the Change but-
ton and browsing to a new directory if required.

ENTER LICENSE DETAILS
You can run Info-Explorer without an activation code for a 30-day trial period.

You can continue using Info-Explorer Lite beyond the trial period by requesting an activ-
ation code.

If you have purchased the product and have an activation code, enter it

For details on requesting an activation code, refer to Register Info-Explorer on page 11

Note: If installing with a 30 day trial period, additional re-installations will not extend
the trial period.
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UPGRADING FROM A PRIOR VERSION
1. Download the new version install program from the Orchid website
2. Backup your existing cubes and programs
3. Execute the EXE program downloaded (as above for a new install).

You can also choose to Remove a prior version before installing the latest version.

LICENSE AGREEMENT
For Orchid End-User License & Service Agreement, refer to Orchid EULA

Using the File Menu
To run Info-Explorer, Start > All Programs > Info-Explorer. You can add a shortcut to the
taskbar or to the desktop. Click Open Cube or File > Open and open one of the sample
cubes.

The Info-Explorer > File menu 

The File Menu allows you to: 

Open an existing cube
Create a new cube
Save an existing cube
Save the existing cube as a new file name
Close the open cube
Download Sample Cubes
Enter your Info-Explorer registration code
Read the release notes in the About option

Using the File Menu 7 of 48

https://www.orchid.systems/eula-serviceplan
Create-Cube.htm


Info-Explorer

Requirement!
if you are using Info-Explorer Lite, then "create cube", "export to CSV", "export to
HTML" , "export to MS Excel" and "Worksets" are not available.

Worksets and Writeback are only available if the Info Explorer - Write back licence has
been purchased and activated. If you are using "info-Explorer - Full", then "Worksets"
and Writeback are not available.

Request Activation Codes
If you are using Info-Explorer Lite (free version of Info-Explorer), you can apply for an activ-
ation code to continue using the demonstration cubes after the 30 day trial. 

If you have purchased a licence for Info-Explorer Full or Writeback, you can follow the
same steps to request an activation code.

To enter the activation code for all versions of Info-Explorer, refer to Register Info-
Explorer on page 11.
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LICENCING METHOD
Info-Explorer activation codes depend on the Company Name and the Computer Name
on which the programs are installed. If you upgrade your machine or get a new machine
(i.e. change the Company Name or Computer Name on which Info-Explorer is installed),
you do need to apply for a new activation code.

Info-Explorer activation codes are not dependent on the database that you are con-
necting to or the version of the ERP Application you are running.

Note: You do not need a new activation code when you upgrade from one version of
Sage 300 to another.

TO REQUEST AN ACTIVATION CODE:
After installing Info-Explorer, Select the "File" option (small white cube on the top left
hand side of the main menu in Info-Explorer)

Select File > Enter Registration code

Note the Computer Name.

You can send the screenshot of the Registration screen with the computer name to your
business partner or to Orchid directly.

Note: If using Info-Explorer on a Terminal Server, you only install on the server and
have a licence for the required number of users.

Request Activation Codes 9 of 48
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USE GET ONE HERE LINK
Gather the required information and click on the "get one here" hyperlink and com-
plete the web-site registration form on https://www.info-explorer.com/resources/info-
explorer-registration-form

An activation code will be sent to you within 48 hours.

NEXT STEPS
Enter the Activation Code: Register Info-Explorer below

Getting started with Info-Explorer - Refer to Using Info-Explorer on page 31

Register Info-Explorer

ENTER AN ACTIVATION CODE:
When you have received your activation code, from InfoExplorer menu: 

Select File > Enter Registration code

Copy and paste the activation code sent by Orchid Systems in the Activation Code
box,
Click "Activate"
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NEXT STEPS
Getting started with Info-Explorer - Refer to Using Info-Explorer on page 31

Info-Explorer Lite
Refer to the Info-Explorer.com website for details.

To use Info-Explorer Lite (free version of Info-Explorer) after the 30 day trial, you need an
activation code. To request an activation code, refer to Request Activation Codes on
page 8

USING INFO-EXPLORER LITE WITH DEMO CUBES:
With Info-Explorer Lite, you can only open and refresh Orchid demo cubes available from
Info-Explorer menu > Download sample cubes or the Orchid website.

Note: Some cubes in the Info-Explorer Sample cubes are not available with Info-
Explorer Lite as they require features not available in Info-Explorer Lite.

OTHER LIMITATIONS OF INFO-EXPLORER LITE
1. You cannot "Create Cube"
2. You can only view a single query cube at one time
3. Result sets not being able to be exported to Excel, CSV or HTML.
4. The cube SQL query cannot be amended

Note: Contact your business partner to purchase Info-Explorer Full licence to

create your own cubes, modify the queries or Info-Explorer Write Back for

budgeting and write back to the database functionality.
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Getting Started Steps
The steps below apply to Info-Explorer Lite as well as the Full and Writeback edition.

After installing Info-Explorer, Start > All Programs > Info-Explorer. You can also add a
shortcut to the taskbar or to the Sage 300 desktop.

Requirement!
if you are using Info-Explorer Lite, then "create cube", "export to CSV", "export to
HTML" , "export to MS Excel" and "Worksets" are not available.

Worksets and Writeback are only available if the Info Explorer - Write back licence has
been purchased and activated. If you are using "info-Explorer - Full", then "Worksets"
and Writeback are not available.

For more details, See Also: 14

FOR MORE DETAILS, SEE ALSO: 
Info-Explorer Analysis Tools on Home Tab

Working with Info-Explorer - Home Tab

Using Display, Chart and Dashboard Tabs

Export Overview

Info-Explorer Writeback Overview

Tip:
Process Scheduler Level 1 is required to refresh and distribute cubes automatically.

Refer to Process Scheduler documentation for details on how to refresh the Info
Explorer automatically
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Ten Steps to Implement a Business Intel-
ligence Solution using Orchid Info-Explorer
Getting started with Info-Explorer is really easy as it comes with some pre-defined cubes
to analyse your data including sales analysis, Purchase analysis, GL detail analysis , AP
aged analysis, AP analysis by GL account, AR aged analysis, AR analysis by GL Account.

To ensure you get the most of Info-Explorer beyond the sample cubes, we have
developed the following 10 steps:

STEP 1.CLARIFY THE OBJECTIVES YOU EXPECT
FROM INFO-EXPLORER
What are the key drivers of your business that you want to monitor, what areas of the busi-
ness are cause for concern, what matters to your clients (Response time to support cases,
low level of back orders, ) what questions are you always asked by senior management, is
budgeting and forecasting part of the project.

Will you need to write data back to an accounting application for budgeting and fore-
casting purposes?

Who needs to receive updated cubes? How often do you need to refresh the data?

STEP 2.REVIEW THE SAMPLE CUBES PROVIDED
WITH INFO-EXPLORER
There is a wide range of sample cubes on Sage 300 and Spire data and new sample cubes
are added regularly. All you need to do is setup the connection to your data from a work-
station that can connect to the database.

Determine which cubes answer the questions from Step 1 and what additional info is
required.

Refer to the following tutorials to get started with the demo cubes: 

Getting Started with Info-Explorer for Spire on page 25

Getting Started with Info-Explorer for Sage 300 on page 21

Ten Steps to Implement a Business Intelligence Solution using Orchid Info-
Explorer
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STEP 3. SOURCE THE DATA THAT ISN’T IN THE
SAMPLE CUBES
Make sure what you want to report on is captured in a database, ERP, CRM or other.
Spreadsheets are great to store data, but not so great to put in a cube for on-going ana-
lysis.

If some elements of the data are missing, consider adding a field to CRM, using Optional
fields in Sage 300, a new dimension in other accounting applications.

Write your query or get consultants to help. Generally once the basic query to return the
data is written, it doesn’t need to be done again. Generally, the query should only return
the records you are interested in for performance reasons and to keep the cube as small
as possible. If you have many rows being returned by your query, it is a good idea to
group the data by the relevant columns (dimensions) by which you want to analyse your
data.

STEP 4. CONFIRM YOUR FACTS AND
DIMENSIONS
Create the first view of the data, facts and dimension. For example, sales by customer and
year.

Dimensions include region, department, type of customer, type of product, type of cases,
reseller, all dates for example transaction date, date the case is created, expected due date
of an order

Note about Date dimensions – Generally Year /Quarter and Months are created auto-
matically if the underlying field is a date.

If doing Fiscal year and fiscal period, you need to write the formula in the query to
retrieve the Fiscal Year and Fiscal period and add a new dimension to calculate quarter if it
is required.

Facts from ERP include number of companies, sales, cost, quantity sold, number of cases,
number of transactions.

Calculated facts include margin, margin %,

If required, create new formulas, for example margin, margin %, show each category as a
% of the total row.
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STEP 5.DRAG AND DROP DIMENSIONS
If the default view shows Sales by month and region, you can Swap the rows and columns
to show Sales by Region and Month in 1 click. If you want to keep both views, you can
copy the view and then swap, creating two quite different representations of the inform-
ation in just 2 clicks.

STEP 6.ADD FILTERS
Filters allow you to focus on some particular records.

Simple dimension filter works well if there are only a few values in a dimension. This is
selected by clicking on the “blue highlighted filter” on the appropriate dimension.

Pre-filters are useful if you are want to focus a view on a particular year or a particular cat-
egory of items or group of customers. They allow you to select multiple conditions and
can be turned on/off with a single tick.

Refer to : 

Filter a dimension or fact

Filter Calculated Fact Values Details

STEP 7. SETUP DASHBOARD
Dashboards are a group of cube views and charts and can include information from vari-
ous cubes and queries. So you could use the dashboard to show sales by product in 2 dif-
ferent ERP companies by placing the view or graph from the one company beside the
view or graph from the second company.

STEP 8. SETUP WRITEBACK
If using Info Explorer for budgeting purposes, create the view that will serve as the basis
for the forecast and budget. Identify how the first budget version will be estimated (for
example last year sales + %,). Determine where the budget should be stored, GL budget,
Inventory – sales by item, custom entity.

Ten Steps to Implement a Business Intelligence Solution using Orchid Info-
Explorer
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STEP 9. SETUP SECURITY
If required, determine who should be able to refresh the data, update the cube, write
data back to ERP and setup the cube security properties.

Refer to Security Considerations below

STEP 10. REFRESH DATA AND DISTRIBUTE THE
CUBE
If the cube is saved on a shared drive, all colleagues with Info-Explorer with access to the
drive can view the data.

There are several ways to refresh cubes, depending on your requirements and the data-
bases you are connecting to. Refer to Refresh Info-Explorer Cubes on page 43

Security Considerations
When the data is extracted from your ERP Applicationand put into a cube, then any data
in the cube will be visible to that Info Explorer user.

It is advised to use a database user that has Read-Only rights to the database (except
where you are using Info-Explorer Writeback to update budget figures). This is configured
outside of Info-Explorer.

You can lock Files and Cubes to protect data once it is being extracted. You can also lock
the actual query to ensure that users only view the data they are entitled to see.

Example: So if you are concerned about a user seeing GL data in Info Explorer, you
need to ensure the user only has access to cubes that don't include GL data and lock
the query so that they can't amend the query. Typically, this requires a unique data cube
for that user that only shows data you want them to see.

Note: If you were Drilling through the cube into Sage 300 underlying screens, then you
would need to log into Sage 300 with an ID and Password and the security settings in
Sage 300 would apply any restrictions on what that user could see. only applicable to
Sage 300
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Clicking Properties on the Home Ribbon will allow you to define and change the
existing properties of the cube.

Use the Options > Lock buttons to set passwords on selected functions in Info-Explorer.

Refer to Configure Lock Options in Info-Explorer below for details.

Configure Lock Options in Info-Explorer

Clicking Properties on the Home Ribbon will allow you to define and change the
existing properties of the cube.

Use the Options > Lock buttons to set passwords on selected functions in Info-Explorer.

OPTIONS : SECURITY OPTIONS FOR THE CUBE.
You can set a password for the following function in Info-Explorer. Users are prompted to
enter the password before they can change the cube configuration or run the locked pro-
cess, such as Refreshing the cube.

REMOVE THE LOCK
To remove the lock, enter the Old Password and leave the password blank (for New and
Confirm).

Configure Lock Options in Info-Explorer 19 of 48
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Tip: There is no master password. If you don't remember the password, the file may
become unusable. We suggest to save a copy of the unprotected file in a secure folder
that only Admin users have access to. You need to enter the existing

WHEN TO USE LOCK OPTIONS
Lock File: Users need a password to open an entire .cubx file
Lock Connections: Users need to enter the password to view/change the con-
nection parameters. This is useful to ensure users cannot change the database that
the cube is pointing to.
Lock Cubes: Users need to enter the password before viewing or amending the
query. This is relevant when you want to restrict what tables/entities are included in
the cube.
Lock Refresh: Users need to enter the password to refresh the cube. This is often
used for large cubes and in conjunction with using automated processes to refresh
the cubes outside of business hours.
Lock Writeback: Users need a password to write to the ERP Application database
and update the budget/forecast data with the currently selected Workset. 
Lock Writeback Query: Users need a password to change the query being used
and therefore the data being updated in the ERP Application when using the Write-
back function.

See Also: 

Home Ribbon > Properties

Security Considerations on page 18
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Getting Started with Info-Explorer for Sage
300
Sample cubes are provided for Sage 300 databases. They include standard queries rel-
evant for Sage 300 users. When you open the sample cube, you will see data from the
Sage 300 sample data to illustrate the dashboard, charts and analysis capabilities of Info-
Explorer.

STEP 1. DOWNLOAD SAMPLE CUBES
Cubes are available for:

Sage 300 GL, AR, AP, PO, PJC, IC, OE/Sales Analysis
Sage 300 US & Canadian Payroll
Orchid Extender, RMA, Bin Tracking
Budget Analysis
Selected 3rd Party products

From Info-Explorer, Click File > Download Sample Cubes

Getting Started with Info-Explorer for Sage 300 21 of 48
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To download the cube, click on the cube you would like, this will open the cube in Info-
Explorer.

Save the cube using File > Save as . and choose where to save the cube.
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STEP 2. UPDATE CONNECTION DETAILS
You can connect the sample cubes to your data.

Select Properties on the Home Ribbon: 

Click on the appropriate connection
Amend the connection details.
The details to provide depend on the database type.

Database Type = Microsoft SQL Server
Database User ID - It is recommended to create a dedicated user in the database
with the minimum security rights required to read data in the appropriate data-
bases.
Database Password
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Server / Datasource
Database - Name of the SQL Server database

Note: When using Sage 300, the Database name can be different from the
Sage Database ID. The user name and password are not the details you use to
login to Sage 300 application. They are details to connect to the SQL database.

Example:

Using Sage 300

Refer to Connect to a database on page 37 for details.

Save the cube using File > Save as . and choose where to save the cube.

STEP 3. REFRESH THE DATA

to refresh the cube data.

Refresh cube manually on page 43
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STEP 4. START ANALYSING YOUR DATA
You can Change what you view in Info-Explorer by changing the dimensions, creating new
views, charts and dashboards.

You can view details using Drill-down to underlying records: Drill down to underlying
transactions.

In many cubes, you can also Drill-through to open the Sage 300 screens: Drill Through to
dimension value

Getting Started with Info-Explorer for Spire
To start using Info-Explorer, you need a cube file. In most cases, you start with Orchid
demo cubes.

Note: Available since May 2023 on the Info-Explorer website https://www.info-explorer-
.com/resources/cubes.

STEP 1. DOWNLOAD SAMPLE CUBES
Sample cubes are provided for Spire databases. They include standard queries relevant for
Spire users. When you open the sample cubes, you will see data from the Spire sample
data to illustrate the dashboard, charts and analysis capabilities of Info-Explorer.

You can create your own cubes and connect to the Spire databases using ODBC.

Cubes are available for:

Spire GL, AR, AP, Purchase Orders, Inventory, Order/Sales Analysis

From Info-Explorer, Click File > Download Sample Cubes

Getting Started with Info-Explorer for Spire 25 of 48
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To download the cube, click on the cube you would like, this will open the
cube in Info-Explorer.

Save the cube using File > Save as . and choose where to save the
cube.
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STEP 2. UPDATE CONNECTION DETAILS
You update the connection details to connect the sample cubes to your data.

Select Properties on the Home Ribbon: 

Click on the appropriate connection
Amend the connection details.
The details to provide depend on the database type.

Connection Details when Using Spire

Step 1. Prerequisite to setup Spire ODBC
You need a 64-bit ODBC connection to the Spire database to use Info-Explorer.
You can use an existing connection or create a new one.
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In most cases, you need to add some lines to the Spire pg_hba file on the
Spire server as follows:

File: "C:\ProgramData\Spire\PostgreSQL\14\pg_hba.conf"

Spire pg_hba file

host   all        spireapp   fe80::/64
  md5
host   all        spireapp   samenet
  md5

The ODBC Credentials can be found in the spire.ini file in C:\Pro-
gramData\Spire for spireapp

Note: Contact your Spire partner for assistance with setting up the
ODBC connection.

Step 2. Install 64-bit PostgreSQL ODBC Driver
As Info-Explorer is a 64-bit application, you need to download and install
the 64-bit ODBC driver on machines used to refresh the cube.

Refer to PostgreSQL site to download the ODBC driver. https://www.-
postgresql.org/ftp/odbc/versions/msi/

Step 3. Create an ODBC Connection to the Post-
greSQL database
Data Source Name: This name will be used in Info-Explorer

Database: Enter the Database Name that you want to analyse with Info-Explorer

User: Enter a database user that has rights to read the database.

Tip: You can use the credentials found in the spire.ini file in the c:\Pro-
gramData\Spire folder on spireapp mentioned above or create a dedicated
user with sufficient rights to the database.
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Step 4. Update Connection Details in Info-Explorer
Database Type : ODBC

Option 1: Use ODBC Connection

Connection String: If you have setup an ODBC connection, enter DSN-
N=ConnectionName in Info-Explorer > Properties > Connection

In the example below, the DSN is called PostgreSQL64
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Option 2: Use full connection string

Alternatively, you can enter the full Connection String with the following
details
DSN-

=Pos-

stgreSQL30;HOST=localhost;DB=inspire+2022;UID=user;

PWD=passwd;PORT=5432;

Step 5. Test the Connection
Use the Test Connection button to ensure the connection is successful.

Troubleshooting the connection
If you get an ODBC error 22P05, error: character with byte sequence in encoding
UTF8 has no equivalent in encoding WIN1252, change the driver from "Post-
greSQL ANSI(x64)" to "PostgreSQL Unicode(x64)", then restart Info-Explorer and
check if it works ok.

Step 6. Save the cube
Save the Cube and Refresh the Data.

Refer to Connect to a database on page 37 for details.

Save the cube using File > Save as . and choose where to save the cube.

STEP 3. REFRESH THE DATA

to refresh the cube data.

Refer to Refresh cube manually on page 43
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STEP 4. START ANALYSING YOUR DATA
You can Change what you view in Info-Explorer by changing the dimensions, creating new
views, charts and dashboards.

You can view details using Drill-down to underlying records: Drill down to underlying
transactions.

Using Info-Explorer
To start using Info-Explorer, you need a cube file. In most cases, you start with Orchid
demo cubes.

To download sample cubes, save, open and close cubes, refer to the topics below:

Most of the actions above are accessible on the Home Ribbon > Quick Links

Download Sample Cubes
Sample Info-Explorer cubes are available on the Info-Explorer website https://www.info-
explorer.com/resources/cubes.

They can also be accessed from the application.

Sample cubes are provided for Sage 300 and Spire databases. They include standard quer-
ies relevant for users of those applications. When you open the sample cube, you will see
data from sample data to illustrate the dashboard, charts and analysis capabilities of Info-
Explorer.

Using Info-Explorer 31 of 48
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CUBES ARE AVAILABLE FOR:
Spire Order Sales analysis, Purchase Order Analysis, Accounts Payable, Accounts
Receivable and General Ledger.
Sage 300 GL, AR, AP, PO, PJC, IC, OE/Sales Analysis
Sage 300 US & Canadian Payroll
Orchid Extender, RMA, Bin Tracking
Budget Analysis
Selected 3rd Party products

STEPS TO USE THE CUBES
1. From Info-Explorer, Click File > Download Sample Cubes
2. To download the cube, click on the cube you would like. This will open the cube in

Info-Explorer.

3. Save the cube using File > Save as . and choose where to save the cube.
4. You can connect the sample cubes to your data. Connect cube to your database on

page 36
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Open a cube

To open a cube, go File>Open . , and select the cube (  .cubx file extension).

To open an existing cube, click File>Open File and specify the file path and cube name
accordingly, or select the required document from the Recent Documents list.

If you open multiple cubes files, you will have multiple tabs, one per cube file.

Tip: The asterisk "*" beside a cube file name indicates unsaved changes have been
made. If you close this cube file without saving, you will be prompted if you want to lose
the changes.  
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Save a cube
To save a new configuration of a cube, click File>Save or click on (to overwrite the
existing cube) or File> Save As (to create a new cube and provide a new file name)

You should save a cube after

you have configured your cube to point to a new database
new formatting has been applied
a new cube has been created
a new view has been created
a new chart has been created
a new dashboard has been created
an existing view, chart or dashboard has been amended or re-configured
the data has been refreshed

if these changes are required to be preserved
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Close a cube

will close the currently active cube.

Connect cube to your database
Info-Explorer reads data and populates the cube through a connection to the database.

For most users, the database is Microsoft SQL Server or an ODBC connection.

To connect to your databases, review the content below.

Tip: The same steps are used to change the connection details from one database to
another and when your database connection details change.
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Important! if you are using Info-Explorer Lite, you can connect to your own

databases, but you need to use the queries defined in Orchid's demo cube.

Connect to a database
Info-Explorer needs a connection to the database to read and refresh data.

Info-Explorer supports the following connections: Microsoft SQL Server, IBM DB2,
Oracle, Pervasive.SQL and ODBC

To configure an existing cube to a database, you need to update the connection details,
save the cube and refresh the data.

Select Properties on the Home Ribbon: 

Click on the appropriate connection
Amend the connection details.
The details to provide depend on the database type.

DATABASE TYPE = MICROSOFT SQL SERVER
This is used for Sage 300 data, Sage CRM data or other Microsoft SQL Server databases.
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Database Type = Microsoft SQL Server
Database User ID - It is recommended to create a dedicated user in the database
with the minimum security rights required to read data in the appropriate data-
bases.
Database Password
Server / Datasource
Database - Name of the SQL Server database

Note: When using Sage 300, the Database name can be different from the
Sage Database ID. The user name and password are not the details you use to
login to Sage 300 application. They are details to connect to the SQL database.

Example:

Using Sage 300

DATABASE TYPE = ODBC
This is used for Spire database.
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Important!
As Info-Explorer is a 64-bit application, you need to download and install the
64-bit ODBC driver for the database you use on machines used to refresh the
cube.

1. Create an ODBC Connection using the 64-bit ODBC driver. Enter details of a data-
base user that has rights to read the database on the server/machine where you
need to connect to the database and refresh the data.

2. In Info-Explorer > Properties > Connections, Select Database Type = ODBC
3. Enter the ODBC connection name

4. You can also enter the full details in the connection string. In most cases, the con-
nection string includes the DSN Name, the HOST, DB, UID, PWD and PORT Number.

SPIRE ODBC DETAILED STEPS

Step 1. Prerequisite to setup Spire ODBC
You need a 64-bit ODBC connection to the Spire database to use Info-Explorer. You can
use an existing connection or create a new one.

In most cases, you need to add some lines to the Spire pg_hba file on the Spire
server as follows:

File: "C:\ProgramData\Spire\PostgreSQL\14\pg_hba.conf"

Spire pg_hba file

host   all        spireapp   fe80::/64   md5
host   all        spireapp   samenet   md5

The ODBC Credentials can be found in the spire.ini file in C:\ProgramData\Spire
for spireapp
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Note: Contact your Spire partner for assistance with setting up the ODBC connection.

Step 2. Install 64-bit PostgreSQL ODBC Driver
As Info-Explorer is a 64-bit application, you need to download and install the 64-
bit ODBC driver on machines used to refresh the cube.

Refer to PostgreSQL site to download the ODBC driver. https://www.-
postgresql.org/ftp/odbc/versions/msi/

Step 3. Create an ODBC Connection to the PostgreSQL
database
Data Source Name: This name will be used in Info-Explorer

Database: Enter the Database Name that you want to analyse with Info-Explorer

User: Enter a database user that has rights to read the database.

Tip: You can use the credentials found in the spire.ini file in the c:\ProgramData\Spire
folder on spireapp mentioned above or create a dedicated user with sufficient rights to
the database.
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Step 4. Update Connection Details in Info-Explorer
Database Type : ODBC

Option 1: Use ODBC Connection

Connection String: If you have setup an ODBC connection, enter DSN-
N=ConnectionName in Info-Explorer > Properties > Connection

In the example below, the DSN is called PostgreSQL64
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Option 2: Use full connection string

Alternatively, you can enter the full Connection String with the following details
DSN=PostgreSQL30;HOST=localhost;DB=inspire+2022;UID=user;

PWD=passwd;PORT=5432;

Step 5. Test the Connection
Use the Test Connection button to ensure the connection is successful.

Troubleshooting the connection
If you get an ODBC error 22P05, error: character with byte sequence in encoding UTF8 has
no equivalent in encoding WIN1252, change the driver from "PostgreSQL ANSI(x64)" to
"PostgreSQL Unicode(x64)", then restart Info-Explorer and check if it works ok.

Step 6. Save the cube
Save the Cube and Refresh the Data.

NOTEWORTHY
Use "test connection" to verify your details.
The connection details are used when refreshing the data. If you send an existing
cube to a user who doesn't have access to the SQL Database or the
ODBC Connection, they can still analyse the data in the cube, but they can't refresh
the data.
It is recommended to save the cube after updating the database properties to save
the database settings. Refer to Save a cube on page 35

Refresh data
Then click "refresh" to update the cube's data. Refer to Refresh cube manually on the next
page
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Connect to Sage 300
This is used to drill-down to the Sage 300 screen when configured in the cube.

Note: This is not used to refresh the data.

Click this icon to connect to Sage 300 (formerly Accpac). You will only see this icon if
a Sage 300 workstation setup has been run on the workstation. 

Enter the Sage 300 Database ID (not the SQL database name), User name and password
you use to log on to Sage 300.

Refresh Info-Explorer Cubes
There are several options to refresh Info-Explorer cubes: 

1. Manually in Info-Explorer : Refer to Refresh cube manually below
2. Configure Auto-Refresh while using the cube: Refer to Auto Refresh Option.
3. Configure Refresh on Opening the cube - Go to the Home > Properties > Cubes

> Select a cube.
4. Refresh automatically without using the application: Refresh Cube with Command

Line on the facing page
5. If using Sage 300, you can use Process Scheduler Level 1 to refresh and email the

cubes to selected users. Refer to Process Scheduler Help for details: 
Process Scheduler help - Refresh Info-Explorer Cube

Tip:
You can lock the Refresh Option if you don't want all users to connect to the database
too often.

Refer to Configure Lock Options in Info-Explorer on page 19

Refresh cube manually
to refresh the cube data.

Connect to Sage 300 43 of 48

../../../../../Content/InfoExp-General/Auto-Refresh.htm
https://help.orchid.systems/sage300addons/Content/Process-Scheduler/OZ-Tutorials/Schedules-Refresh-Info-Explorer-Cube.htm


Info-Explorer

If you have multiple queries, you will see a “down arrow” below Refresh, allowing you to
refresh “All Cubes” or each individual cube in your cube file.

All current formatting, views etc will be preserved.

Tip: You can lock the ability to refresh the data with a password. Refer to Configure
Lock Options in Info-Explorer on page 19

Refresh Cube with Command Line
You can run Info-Explorer from the command line, by passing the cube name, and if
required Passwords and Parameters to refresh the cube.

Tip: If using Sage 300, you can use Process Scheduler Level 1 to refresh and email the
cubes to selected users. Refer to Process Scheduler Help for details: 
Process Scheduler help - Refresh Info-Explorer Cube

There are two main options to run the program, with the UI or without: 

Refresh the cube without opening a UI. This is useful to refresh the cube overnight
unattended. Users can then open the cube with the latest data without having to
refresh manually.
Refresh and leave the cube open for analysis. This makes the parameters hidden, so
you are not prompted and don't have to click OK. If you have parameters for the
cube, you have an option to refresh, close and re-open the cube with the correct
parameters.

COMMAND LINE SYNTAX
Run the CMD program and navigate to where Info-Explorer is installed.

The program to run is InfoExplorer.exe
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Enter the full path and cube file name, surrounded by double quotes ("") to cater for
spaces in file path and file names.

Functions
/REFRESH - Refreshes the cube

/CLOSE - Closes Info-Explorer after refreshing

/NOUI - Does not show any UI for parameters or passwords or the refreshed cube for ana-
lysis

Parameters
Parameters are passed by specifying the parameter name, equals sign and then the para-
meter value.

EXAMPLE
Info-Explorer is installed in the Default folder c:\Program Files\Orchid Systems\Info-
Explorer
Cubes are in a folder called c:\Orchid\InfoExplorerCubes
To refresh the ARCustomerCube.cubx file, without opening the Info-Explorer applic-
ation, use the following command line
This assumes the ARCustomerCube file doesn't have any parameters or the para-
meters are hidden and the default values will be used when refreshing

Refresh and Do not open Info-Explorer UI
In the example below, use /REFRESH /CLOSE /NOUI

Refresh cube at command line - no UI

>c:\Program Files\Orchid Systems\Info-Explorer>infoexplorer.exe /REFRESH
/NOUI /CLOSE 
"c:\Orchid\InfoExplorerCubes\ARCustomerCube.cubx"

Refresh and open Info-Explorer UI
In the example below, use /REFRESH -
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The cube will be refreshed and Info-Explorer application opened.

Refresh cube and open UI at command line

>c:\Program Files\Orchid Systems\Info-Explorer>infoexplorer.exe /REFRESH  
"c:\Orchid\InfoExplorerCubes\ARCustomerCube.cubx"

Set parameters to the cube
If the cube has 2 parameters called CUSTOMER and STARTDATE, you can set the para-
meters in the command line, using the parameter name.

Refresh cube with parameters

>c:\Program Files\Orchid Systems\Info-Explorer>infoexplorer.exe 
STARTDATE=2020 CUSTOMER=1200 /REFRESH  
"c:\Orchid\InfoExplorerCubes\ARCustomerCube.cubx"
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