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Installing Info-Explorer
The steps below apply to Info-Explorer Lite as well as the Full and Writeback edition.

Next Steps: 8
Installing Info-Explorer 8
Using the File Menu 9
Request Activation Codes 10
Register Info-Explorer 12
Info-Explorer Lite 14

NEXT STEPS: 
Getting Started Steps on page 15

Refer to Info-Explorer Training Guide for further details

INSTALLING INFO-EXPLORER
Info Explorer is installed by executing the EXE program downloaded from the Info-Explorer website.

Use the following link: https://www.info-explorer.com/resources/downloads

InstallShield will execute and guide you through the installation steps.

Re-installations over-write existing installations on the target directory.

Note: You can change the default installation directory by clicking on the Change button and brows-
ing to a new directory if required.

Enter License Details
You can run Info-Explorer without an activation code for a 30-day trial period.

You can continue using Info-Explorer Lite beyond the trial period by requesting an activation code.

If you have purchased the product and have an activation code, enter it

For details on requesting an activation code, refer to Register Info-Explorer on page 12

Note: If installing with a 30 day trial period, additional re-installations will not extend the trial period.
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Upgrading from a Prior version
1. Download the new version install program from the Orchid website
2. Backup your existing cubes and programs
3. Execute the EXE program downloaded (as above for a new install).

You can also choose to Remove a prior version before installing the latest version.

License Agreement
For Orchid End-User License & Service Agreement, refer to Orchid EULA

USING THE FILE MENU
To run Info-Explorer, Start > All Programs > Info-Explorer. You can add a shortcut to the taskbar or to
the desktop. Click Open Cube or File > Open and open one of the sample cubes.

The Info-Explorer > File menu 

The File Menu allows you to: 

Open an existing cube
Create a new cube
Save an existing cube
Save the existing cube as a new file name
Close the open cube
Download Sample Cubes
Enter your Info-Explorer registration code
Read the release notes in the About option
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Requirement!
if you are using Info-Explorer Lite, then "create cube", "export to CSV", "export to HTML" , "export to
MS Excel" and "Worksets" are not available.

Worksets and Writeback are only available if the Info Explorer - Write back licence has been purchased
and activated. If you are using "info-Explorer - Full", then "Worksets" and Writeback are not available.

REQUEST ACTIVATION CODES
If you are using Info-Explorer Lite (free version of Info-Explorer), you can apply for an activation code to
continue using the demonstration cubes after the 30 day trial. 

If you have purchased a licence for Info-Explorer Full or Writeback, you can follow the same steps to
request an activation code.

To enter the activation code for all versions of Info-Explorer, refer to Register Info-Explorer on page 12.

Licencing method
Info-Explorer activation codes depend on the Company Name and the Computer Name on which the
programs are installed. If you upgrade your machine or get a new machine (i.e. change the Company
Name or Computer Name on which Info-Explorer is installed), you do need to apply for a new activation
code.
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Info-Explorer activation codes are not dependent on the database that you are connecting to or the ver-
sion of the ERP Application you are running.

Note: You do not need a new activation code when you upgrade from one version of Sage 300 to
another.

To Request an activation code:
After installing Info-Explorer, Select the "File" option (small white cube on the top left hand side of the
main menu in Info-Explorer)

Select File > Enter Registration code

Note the Computer Name.

You can send the screenshot of the Registration screen with the computer name to your business part-
ner or to Orchid directly.

Note: If using Info-Explorer on a Terminal Server, you only install on the server and have a licence for
the required number of users.
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Use Get One Here link
Gather the required information and click on the "get one here" hyperlink and complete the web-
site registration form on https://www.info-explorer.com/resources/info-explorer-registration-form

An activation code will be sent to you within 48 hours.

Next steps
Enter the Activation Code: Register Info-Explorer below

Getting started with Info-Explorer - Refer to Using Info-Explorer on page 29

REGISTER INFO-EXPLORER

Enter an activation code:
When you have received your activation code, from InfoExplorer menu: 

Select File > Enter Registration code

Copy and paste the activation code sent by Orchid Systems in the Activation Code box,
Click "Activate"
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Next steps
Getting started with Info-Explorer - Refer to Using Info-Explorer on page 29
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INFO-EXPLORER LITE
Refer to the Info-Explorer.com website for details.

To use Info-Explorer Lite (free version of Info-Explorer) after the 30 day trial, you need an activation
code. To request an activation code, refer to Request Activation Codes on page 10

Using Info-Explorer Lite with Demo Cubes:
With Info-Explorer Lite, you can only open and refresh Orchid demo cubes available from Info-Explorer
menu > Download sample cubes or the Orchid website.

Note: Some cubes in the Info-Explorer Sample cubes are not available with Info-Explorer Lite as they
require features not available in Info-Explorer Lite.

Other Limitations of Info-Explorer Lite
1. You cannot "Create Cube"
2. You can only view a single query cube at one time
3. Result sets not being able to be exported to Excel, CSV or HTML.
4. The cube SQL query cannot be amended

Note: Contact your business partner to purchase Info-Explorer Full licence to create your

own cubes, modify the queries or Info-Explorer Write Back for budgeting and write back to

the database functionality.
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Getting Started Steps
The steps below apply to Info-Explorer Lite as well as the Full and Writeback edition.

After installing Info-Explorer, Start > All Programs > Info-Explorer. You can also add a shortcut to the
taskbar or to the Sage 300 desktop.

Requirement!
if you are using Info-Explorer Lite, then "create cube", "export to CSV", "export to HTML" , "export to
MS Excel" and "Worksets" are not available.

Worksets and Writeback are only available if the Info Explorer - Write back licence has been purchased
and activated. If you are using "info-Explorer - Full", then "Worksets" and Writeback are not available.

For more details, See Also: 15
Ten Steps to Implement a Business Intelligence Solution using Orchid Info-Explorer 15
Security Considerations 18
Configure Lock Options in Info-Explorer 18
Getting Started with Info-Explorer for Sage 300 20
Getting Started with Info-Explorer for Spire 24

FOR MORE DETAILS, SEE ALSO: 
Info-Explorer Analysis Tools on page 43

Working with Info-Explorer - Home Tab on page 74

Using Charts and Dashboards on page 89

Export Overview on page 99

Info-Explorer Writeback on page 115

Tip:
Process Scheduler Level 1 is required to refresh and distribute cubes automatically.

Refer to Process Scheduler documentation for details on how to refresh the Info Explorer automatically

TEN STEPS TO IMPLEMENT A BUSINESS INTELLIGENCE
SOLUTION USING ORCHID INFO-EXPLORER
Getting started with Info-Explorer is really easy as it comes with some pre-defined cubes to analyse your
data including sales analysis, Purchase analysis, GL detail analysis , AP aged analysis, AP analysis by GL
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account, AR aged analysis, AR analysis by GL Account.

To ensure you get the most of Info-Explorer beyond the sample cubes, we have developed the following
10 steps:

Step 1.Clarify the objectives you expect from Info-Explorer
What are the key drivers of your business that you want to monitor, what areas of the business are cause
for concern, what matters to your clients (Response time to support cases, low level of back orders, )
what questions are you always asked by senior management, is budgeting and forecasting part of the
project.

Will you need to write data back to an accounting application for budgeting and forecasting purposes?

Who needs to receive updated cubes? How often do you need to refresh the data?

Step 2.Review the Sample cubes provided with Info-Explorer
There is a wide range of sample cubes on Sage 300 and Spire data and new sample cubes are added reg-
ularly. All you need to do is setup the connection to your data from a workstation that can connect to the
database.

Determine which cubes answer the questions from Step 1 and what additional info is required.

Refer to the following tutorials to get started with the demo cubes: 

Getting Started with Info-Explorer for Spire on page 24

Getting Started with Info-Explorer for Sage 300 on page 20

Step 3. Source the data that isn’t in the sample cubes
Make sure what you want to report on is captured in a database, ERP, CRM or other. Spreadsheets are
great to store data, but not so great to put in a cube for on-going analysis.

If some elements of the data are missing, consider adding a field to CRM, using Optional fields in Sage
300, a new dimension in other accounting applications.

Write your query or get consultants to help. Generally once the basic query to return the data is written,
it doesn’t need to be done again. Generally, the query should only return the records you are interested
in for performance reasons and to keep the cube as small as possible. If you have many rows being
returned by your query, it is a good idea to group the data by the relevant columns (dimensions) by
which you want to analyse your data.

Step 4. Confirm your facts and dimensions
Create the first view of the data, facts and dimension. For example, sales by customer and year.

Dimensions include region, department, type of customer, type of product, type of cases, reseller, all
dates for example transaction date, date the case is created, expected due date of an order
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Note about Date dimensions – Generally Year /Quarter and Months are created automatically if the
underlying field is a date.

If doing Fiscal year and fiscal period, you need to write the formula in the query to retrieve the Fiscal
Year and Fiscal period and add a new dimension to calculate quarter if it is required.

Facts from ERP include number of companies, sales, cost, quantity sold, number of cases, number of
transactions.

Calculated facts include margin, margin %,

If required, create new formulas, for example margin, margin %, show each category as a % of the total
row.

Step 5.Drag and drop dimensions
If the default view shows Sales by month and region, you can Swap the rows and columns to show Sales
by Region and Month in 1 click. If you want to keep both views, you can copy the view and then swap,
creating two quite different representations of the information in just 2 clicks.

Step 6.Add Filters
Filters allow you to focus on some particular records.

Simple dimension filter works well if there are only a few values in a dimension. This is selected by click-
ing on the “blue highlighted filter” on the appropriate dimension.

Pre-filters are useful if you are want to focus a view on a particular year or a particular category of items
or group of customers. They allow you to select multiple conditions and can be turned on/off with a
single tick.

Refer to : 

Filter a dimension or fact on page 51

Filter Calculated Fact Values Details on page 56

Step 7. Setup Dashboard
Dashboards are a group of cube views and charts and can include information from various cubes and
queries. So you could use the dashboard to show sales by product in 2 different ERP companies by pla-
cing the view or graph from the one company beside the view or graph from the second company.

Step 8. Setup writeback
If using Info Explorer for budgeting purposes, create the view that will serve as the basis for the forecast
and budget. Identify how the first budget version will be estimated (for example last year sales + %,).
Determine where the budget should be stored, GL budget, Inventory – sales by item, custom entity.
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Step 9. Setup security
If required, determine who should be able to refresh the data, update the cube, write data back to ERP
and setup the cube security properties.

Refer to Security Considerations below

Step 10. Refresh data and distribute the cube
If the cube is saved on a shared drive, all colleagues with Info-Explorer with access to the drive can view
the data.

There are several ways to refresh cubes, depending on your requirements and the databases you are con-
necting to. Refer to Refresh Info-Explorer Cubes on page 40

SECURITY CONSIDERATIONS
When the data is extracted from your ERP Applicationand put into a cube, then any data in the cube will
be visible to that Info Explorer user.

It is advised to use a database user that has Read-Only rights to the database (except where you are
using Info-Explorer Writeback to update budget figures). This is configured outside of Info-Explorer.

You can lock Files and Cubes to protect data once it is being extracted. You can also lock the actual query
to ensure that users only view the data they are entitled to see.

Example: So if you are concerned about a user seeing GL data in Info Explorer, you need to ensure the
user only has access to cubes that don't include GL data and lock the query so that they can't amend
the query. Typically, this requires a unique data cube for that user that only shows data you want them
to see.

Note: If you were Drilling through the cube into Sage 300 underlying screens, then you would need to
log into Sage 300 with an ID and Password and the security settings in Sage 300 would apply any
restrictions on what that user could see. only applicable to Sage 300

Clicking Properties on the Home Ribbon will allow you to define and change the existing properties
of the cube.

Use the Options > Lock buttons to set passwords on selected functions in Info-Explorer.

Refer to Configure Lock Options in Info-Explorer below for details.

CONFIGURE LOCK OPTIONS IN INFO-EXPLORER
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Clicking Properties on the Home Ribbon will allow you to define and change the existing properties
of the cube.

Use the Options > Lock buttons to set passwords on selected functions in Info-Explorer.

Options : Security options for the cube.
You can set a password for the following function in Info-Explorer. Users are prompted to enter the pass-
word before they can change the cube configuration or run the locked process, such as Refreshing the
cube.

Remove the Lock
To remove the lock, enter the Old Password and leave the password blank (for New and Confirm).
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Tip: There is no master password. If you don't remember the password, the file may become unusable.
We suggest to save a copy of the unprotected file in a secure folder that only Admin users have access
to. You need to enter the existing

When to use Lock options
Lock File: Users need a password to open an entire .cubx file
Lock Connections: Users need to enter the password to view/change the connection parameters.
This is useful to ensure users cannot change the database that the cube is pointing to.
Lock Cubes: Users need to enter the password before viewing or amending the query. This is rel-
evant when you want to restrict what tables/entities are included in the cube.
Lock Refresh: Users need to enter the password to refresh the cube. This is often used for large
cubes and in conjunction with using automated processes to refresh the cubes outside of business
hours.
Lock Writeback: Users need a password to write to the ERP Application database and update the
budget/forecast data with the currently selected Workset. 
Lock Writeback Query: Users need a password to change the query being used and therefore the
data being updated in the ERP Application when using the Writeback function.

See Also: 

Properties: Security, Connections and Parameters on page 102

Security Considerations on page 18

GETTING STARTED WITH INFO-EXPLORER FOR SAGE 300
Sample cubes are provided for Sage 300 databases. They include standard queries relevant for Sage 300
users. When you open the sample cube, you will see data from the Sage 300 sample data to illustrate the
dashboard, charts and analysis capabilities of Info-Explorer.

Step 1. Download sample cubes
Cubes are available for:

Sage 300 GL, AR, AP, PO, PJC, IC, OE/Sales Analysis
Sage 300 US & Canadian Payroll
Orchid Extender, RMA, Bin Tracking
Budget Analysis
Selected 3rd Party products

From Info-Explorer, Click File > Download Sample Cubes

Page 20 of 124 Getting Started Steps



Info-Explorer

To download the cube, click on the cube you would like, this will open the cube in Info-Explorer.

Save the cube using File > Save as . and choose where to save the cube.
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Step 2. Update connection details
You can connect the sample cubes to your data.

Select Properties on the Home Ribbon: 

Click on the appropriate connection
Amend the connection details.
The details to provide depend on the database type.

Database Type = Microsoft SQL Server
Database User ID - It is recommended to create a dedicated user in the database with the min-
imum security rights required to read data in the appropriate databases.
Database Password
Server / Datasource
Database - Name of the SQL Server database
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Note: When using Sage 300, the Database name can be different from the Sage Database
ID. The user name and password are not the details you use to login to Sage 300 applic-
ation. They are details to connect to the SQL database.

Example:

Using Sage 300

Refer to Connect to a database on page 35 for details.

Save the cube using File > Save as . and choose where to save the cube.

Step 3. Refresh the data

to refresh the cube data.

Refresh cube manually on page 40

Step 4. Start Analysing Your data
You can Change what you view in Info-Explorer by changing the dimensions, creating new views, charts
and dashboards.
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You can view details using Drill-down to underlying records: Drill down to view details. on page 69

In many cubes, you can also Drill-through to open the Sage 300 screens: Drill Through to Sage 300
screens on page 70

GETTING STARTED WITH INFO-EXPLORER FOR SPIRE
To start using Info-Explorer, you need a cube file. In most cases, you start with Orchid demo cubes.

Note: Available since May 2023 on the Info-Explorer website https://www.info-explorer-
.com/resources/cubes.

Step 1. Download sample cubes
Sample cubes are provided for Spire databases. They include standard queries relevant for Spire users.
When you open the sample cubes, you will see data from the Spire sample data to illustrate the dash-
board, charts and analysis capabilities of Info-Explorer.

You can create your own cubes and connect to the Spire databases using ODBC.

Cubes are available for:

Spire GL, AR, AP, Purchase Orders, Inventory, Order/Sales Analysis

From Info-Explorer, Click File > Download Sample Cubes
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To download the cube, click on the cube you would like, this will open the cube in Info-
Explorer.

Save the cube using File > Save as . and choose where to save the cube.
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Step 2. Update connection details
You update the connection details to connect the sample cubes to your data.

Select Properties on the Home Ribbon: 

Click on the appropriate connection
Amend the connection details.
The details to provide depend on the database type.

Connection Details when Using Spire

Prerequisite to setup Spire ODBC

You need a 64-bit ODBC connection to the Spire database to use Info-Explorer. You can use an
existing connection or create a new one.

In most cases, you need to add some lines to the Spire pg_hba file on the Spire server
as follows:
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File: "C:\ProgramData\Spire\PostgreSQL\14\pg_hba.conf"

Spire pg_hba file

host   all        spireapp   fe80::/64   md5
host   all        spireapp   samenet   md5

The ODBC Credentials can be found in the spire.ini file in C:\ProgramData\Spire for
spireapp

Note: Contact your Spire partner for assistance with setting up the ODBC connection.

Install 64-bit PostgreSQL ODBC Driver

As Info-Explorer is a 64-bit application, you need to download and install the 64-bit
ODBC driver on machines used to refresh the cube.

Refer to PostgreSQL site to download the ODBC driver. https://www.-
postgresql.org/ftp/odbc/versions/msi/

Create an ODBC Connection to the PostgreSQL database

Data Source Name: This name will be used in Info-Explorer

Database: Enter the Database Name that you want to analyse with Info-Explorer

User: Enter a database user that has rights to read the database.

Tip: You can use the credentials found in the spire.ini file in the c:\ProgramData\Spire folder
on spireapp mentioned above or create a dedicated user with sufficient rights to the data-
base.
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Update Connection Details in Info-Explorer

Database Type : ODBC

Option 1: Use ODBC Connection

Connection String: If you have setup an ODBC connection, enter DSN-
N=ConnectionName in Info-Explorer > Properties > Connection

In the example below, the DSN is called PostgreSQL64

Option 2: Use full connection string

Alternatively, you can enter the full Connection String with the following details
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DSN=PostgreSQL30;HOST=localhost;DB=inspire+2022;UID=user;

PWD=passwd;PORT=5432;

Test the Connection

Use the Test Connection button to ensure the connection is successful.

Troubleshooting the connection

If you get an ODBC error 22P05, error: character with byte sequence in encoding UTF8 has no
equivalent in encoding WIN1252, change the driver from "PostgreSQL ANSI(x64)" to "Post-
greSQL Unicode(x64)", then restart Info-Explorer and check if it works ok.

Save the cube

Save the Cube and Refresh the Data.

Refer to Connect to a database on page 35 for details.

Save the cube using File > Save as . and choose where to save the cube.

Step 3. Refresh the data

to refresh the cube data.

Refer to Refresh cube manually on page 40

Step 4. Start Analysing Your data
You can Change what you view in Info-Explorer by changing the dimensions, creating new views, charts
and dashboards.

You can view details using Drill-down to underlying records: Drill down to view details. on page 69

Using Info-Explorer
To start using Info-Explorer, you need a cube file. In most cases, you start with Orchid demo cubes.

To download sample cubes, save, open and close cubes, refer to the topics below:
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Download Sample Cubes 30
Open a cube 32
Save a cube 33
Connect cube to your database 34

Most of the actions above are accessible on the Home Ribbon > Quick Links

DOWNLOAD SAMPLE CUBES
Sample Info-Explorer cubes are available on the Info-Explorer website https://www.info-explorer.com/re-
sources/cubes.

They can also be accessed from the application.

Sample cubes are provided for Sage 300 and Spire databases. They include standard queries relevant for
users of those applications. When you open the sample cube, you will see data from sample data to illus-
trate the dashboard, charts and analysis capabilities of Info-Explorer.

Cubes are available for:
Spire Order Sales analysis, Purchase Order Analysis, Accounts Payable, Accounts Receivable and
General Ledger.
Sage 300 GL, AR, AP, PO, PJC, IC, OE/Sales Analysis
Sage 300 US & Canadian Payroll
Orchid Extender, RMA, Bin Tracking
Budget Analysis
Selected 3rd Party products

Steps to use the cubes
1. From Info-Explorer, Click File > Download Sample Cubes
2. To download the cube, click on the cube you would like. This will open the cube in Info-Explorer.
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3. Save the cube using File > Save as . and choose where to save the cube.
4. You can connect the sample cubes to your data. Connect cube to your database on page 34
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OPEN A CUBE

To open a cube, go File>Open . , and select the cube (  .cubx file extension).

To open an existing cube, click File>Open File and specify the file path and cube name accordingly, or
select the required document from the Recent Documents list.

If you open multiple cubes files, you will have multiple tabs, one per cube file.

Tip: The asterisk "*" beside a cube file name indicates unsaved changes have been made. If you close
this cube file without saving, you will be prompted if you want to lose the changes.  
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SAVE A CUBE
To save a new configuration of a cube, click File>Save or click on (to overwrite the existing cube) or
File> Save As (to create a new cube and provide a new file name)

You should save a cube after

you have configured your cube to point to a new database
new formatting has been applied
a new cube has been created
a new view has been created
a new chart has been created
a new dashboard has been created
an existing view, chart or dashboard has been amended or re-configured
the data has been refreshed

if these changes are required to be preserved
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Close a cube

will close the currently active cube.

CONNECT CUBE TO YOUR DATABASE
Info-Explorer reads data and populates the cube through a connection to the database.

For most users, the database is Microsoft SQL Server or an ODBC connection.

To connect to your databases, review the content below.

Tip: The same steps are used to change the connection details from one database to another and
when your database connection details change.

Important! if you are using Info-Explorer Lite, you can connect to your own databases, but

you need to use the queries defined in Orchid's demo cube.
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Connect to a database
Info-Explorer needs a connection to the database to read and refresh data.

Info-Explorer supports the following connections: Microsoft SQL Server, IBM DB2,
Oracle, Pervasive.SQL and ODBC

To configure an existing cube to a database, you need to update the connection details, save the cube
and refresh the data.

Select Properties on the Home Ribbon: 

Click on the appropriate connection
Amend the connection details.
The details to provide depend on the database type.

Database Type = Microsoft SQL Server

This is used for Sage 300 data, Sage CRM data or other Microsoft SQL Server databases.

Database Type = Microsoft SQL Server
Database User ID - It is recommended to create a dedicated user in the database with the min-
imum security rights required to read data in the appropriate databases.
Database Password
Server / Datasource
Database - Name of the SQL Server database

Note: When using Sage 300, the Database name can be different from the Sage Database
ID. The user name and password are not the details you use to login to Sage 300 applic-
ation. They are details to connect to the SQL database.
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Example:

Using Sage 300

Database Type = ODBC

This is used for Spire database.

Important!
As Info-Explorer is a 64-bit application, you need to download and install the 64-bit
ODBC driver for the database you use on machines used to refresh the cube.

1. Create an ODBC Connection using the 64-bit ODBC driver. Enter details of a database user that has
rights to read the database on the server/machine where you need to connect to the database and
refresh the data.

2. In Info-Explorer > Properties > Connections, Select Database Type = ODBC
3. Enter the ODBC connection name
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4. You can also enter the full details in the connection string. In most cases, the connection string
includes the DSN Name, the HOST, DB, UID, PWD and PORT Number.

Spire ODBC Detailed steps

Prerequisite to setup Spire ODBC

You need a 64-bit ODBC connection to the Spire database to use Info-Explorer. You can use an existing
connection or create a new one.

In most cases, you need to add some lines to the Spire pg_hba file on the Spire server as fol-
lows:

File: "C:\ProgramData\Spire\PostgreSQL\14\pg_hba.conf"

Spire pg_hba file

host   all        spireapp   fe80::/64   md5
host   all        spireapp   samenet   md5

The ODBC Credentials can be found in the spire.ini file in C:\ProgramData\Spire for spireapp

Note: Contact your Spire partner for assistance with setting up the ODBC connection.

Install 64-bit PostgreSQL ODBC Driver

As Info-Explorer is a 64-bit application, you need to download and install the 64-bit
ODBC driver on machines used to refresh the cube.

Refer to PostgreSQL site to download the ODBC driver. https://www.-
postgresql.org/ftp/odbc/versions/msi/

Create an ODBC Connection to the PostgreSQL database

Data Source Name: This name will be used in Info-Explorer

Database: Enter the Database Name that you want to analyse with Info-Explorer

User: Enter a database user that has rights to read the database.

Tip: You can use the credentials found in the spire.ini file in the c:\ProgramData\Spire folder on spire-
app mentioned above or create a dedicated user with sufficient rights to the database.
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Update Connection Details in Info-Explorer

Database Type : ODBC

Option 1: Use ODBC Connection

Connection String: If you have setup an ODBC connection, enter DSN=ConnectionName in
Info-Explorer > Properties > Connection

In the example below, the DSN is called PostgreSQL64
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Option 2: Use full connection string

Alternatively, you can enter the full Connection String with the following details
DSN=PostgreSQL30;HOST=localhost;DB=inspire+2022;UID=user;

PWD=passwd;PORT=5432;

Test the Connection

Use the Test Connection button to ensure the connection is successful.

Troubleshooting the connection

If you get an ODBC error 22P05, error: character with byte sequence in encoding UTF8 has no equivalent
in encoding WIN1252, change the driver from "PostgreSQL ANSI(x64)" to "PostgreSQL Unicode(x64)",
then restart Info-Explorer and check if it works ok.

Save the cube

Save the Cube and Refresh the Data.

Noteworthy

Use "test connection" to verify your details.
The connection details are used when refreshing the data. If you send an existing cube to a user
who doesn't have access to the SQL Database or the ODBC Connection, they can still analyse the
data in the cube, but they can't refresh the data.
It is recommended to save the cube after updating the database properties to save the database
settings. Refer to Save a cube on page 33
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Refresh data

Then click "refresh" to update the cube's data. Refer to Refresh cube manually below

Connect to Sage 300
This is used to drill-down to the Sage 300 screen when configured in the cube.

Note: This is not used to refresh the data.

Click this icon to connect to Sage 300 (formerly Accpac). You will only see this icon if a Sage 300
workstation setup has been run on the workstation. 

Enter the Sage 300 Database ID (not the SQL database name), User name and password you use to log
on to Sage 300.

Refresh Info-Explorer Cubes
There are several options to refresh Info-Explorer cubes: 

1. Manually in Info-Explorer : Refer to Refresh cube manually below
2. Configure Auto-Refresh while using the cube: Refer to Auto Refresh on page 114 Option.
3. Configure Refresh on Opening the cube - Go to the Home > Properties > Cubes > Select a cube.
4. Refresh automatically without using the application: Refresh Cube with Command Line on the

facing page
5. If using Sage 300, you can use Process Scheduler Level 1 to refresh and email the cubes to selected

users. Refer to Process Scheduler Help for details: 
Process Scheduler help - Refresh Info-Explorer Cube

Tip:
You can lock the Refresh Option if you don't want all users to connect to the database too often.

Refer to Configure Lock Options in Info-Explorer on page 18

REFRESH CUBE MANUALLY

to refresh the cube data.

If you have multiple queries, you will see a “down arrow” below Refresh, allowing you to refresh “All
Cubes” or each individual cube in your cube file.
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All current formatting, views etc will be preserved.

Tip: You can lock the ability to refresh the data with a password. Refer to Configure Lock Options in
Info-Explorer on page 18

REFRESH CUBE WITH COMMAND LINE
You can run Info-Explorer from the command line, by passing the cube name, and if required Passwords
and Parameters to refresh the cube.

Tip: If using Sage 300, you can use Process Scheduler Level 1 to refresh and email the cubes to selec-
ted users. Refer to Process Scheduler Help for details: 
Process Scheduler help - Refresh Info-Explorer Cube

There are two main options to run the program, with the UI or without: 

Refresh the cube without opening a UI. This is useful to refresh the cube overnight unattended.
Users can then open the cube with the latest data without having to refresh manually.
Refresh and leave the cube open for analysis. This makes the parameters hidden, so you are not
prompted and don't have to click OK. If you have parameters for the cube, you have an option to
refresh, close and re-open the cube with the correct parameters.

Command line syntax
Run the CMD program and navigate to where Info-Explorer is installed.

The program to run is InfoExplorer.exe

Enter the full path and cube file name, surrounded by double quotes ("") to cater for spaces in file path
and file names.

Functions

/REFRESH - Refreshes the cube

/CLOSE - Closes Info-Explorer after refreshing
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/NOUI - Does not show any UI for parameters or passwords or the refreshed cube for analysis

Parameters

Parameters are passed by specifying the parameter name, equals sign and then the parameter value.

Example
Info-Explorer is installed in the Default folder c:\Program Files\Orchid Systems\Info-Explorer
Cubes are in a folder called c:\Orchid\InfoExplorerCubes
To refresh the ARCustomerCube.cubx file, without opening the Info-Explorer application, use the
following command line
This assumes the ARCustomerCube file doesn't have any parameters or the parameters are hidden
and the default values will be used when refreshing

Refresh and Do not open Info-Explorer UI

In the example below, use /REFRESH /CLOSE /NOUI

Refresh cube at command line - no UI

>c:\Program Files\Orchid Systems\Info-Explorer>infoexplorer.exe /REFRESH /NOUI
/CLOSE 
"c:\Orchid\InfoExplorerCubes\ARCustomerCube.cubx"

Refresh and open Info-Explorer UI

In the example below, use /REFRESH -

The cube will be refreshed and Info-Explorer application opened.

Refresh cube and open UI at command line

>c:\Program Files\Orchid Systems\Info-Explorer>infoexplorer.exe /REFRESH  
"c:\Orchid\InfoExplorerCubes\ARCustomerCube.cubx"

Set parameters to the cube

If the cube has 2 parameters called CUSTOMER and STARTDATE, you can set the parameters in the com-
mand line, using the parameter name.

Refresh cube with parameters

>c:\Program Files\Orchid Systems\Info-Explorer>infoexplorer.exe 
STARTDATE=2020 CUSTOMER=1200 /REFRESH  
"c:\Orchid\InfoExplorerCubes\ARCustomerCube.cubx"
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Info-Explorer Analysis Tools
Using Info-Explorer, you can change what you view in Info-Explorer. The most commonly used features
are described below:

Reorder and Reorganise your views and charts 43
Drag and Drop Dimensions and Facts 44
Sort a dimension 47
Viewing Facts 50
Filter a dimension or fact 51
Filter Calculated Fact Values Details 56
Format a cube - Using Styles 58
Format a fact - Caption and Styles 63
Create / Amend /Delete a fact 65
Facts vs Dimensions in a cube 68
Drill down to view details. 69
Drill Through to Sage 300 screens 70

REORDER AND REORGANISE YOUR VIEWS AND CHARTS
The views, charts and dashboards within a cube can be reordered and reorganized by dragging and drop-
ping the view/chart/dashboard.

Select the required view/chart/dashboard (by clicking and holding the mouse button down, and the
selected view/chart/dashboard will go blue) and drag the view/chart/dashboard to the required position
as shown by the dark blue line and deselect (let go of the mouse button).
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DRAG AND DROP DIMENSIONS AND FACTS
To change your visible rows and columns on any one view, you can click on a dimension, hold your
mouse button down and drag the dimension to the area you want it to be. For example, if you wish to
see which vendor groups the vendors belong to, you click on Vendor Group, hold your left hand mouse
button down, drag the Vendor Group dimension to the Left of Vendor and let it go.
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To collapse all vendors and vendor documents, click on Collapse icon on the Home Tab
> View Ribbon

To expand all vendor groups, vendors and document numbers, click on Expand icon on the Home
Tab > View  
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SORT A DIMENSION
To sort a dimension, you need to select what fact you will use to sort and the sorting order.

If you don't select a particular fact, the dimension is sorted in alphabetical order of the dimension name.

Select the AsC/Desc order

The sort by dimension icon toggles between sorting the dimension in
ascending and descending order.  

For example below, the Customer dimension is sorted in ascending order, the Item Number dimension in
ascending order.
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Select a fact
You can also sort the dimension based on one of the facts in the view.

Right Hand Mouse button(RHMB)  on the fact name and then select which dimension you want to sort
by.

To sort Customer Number by the Credit Limit, add the Credit Limit to the view, RHMB on the Credit Limit
fact name and select Sort Customer Number by this dimension.
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The "Sort by this column" is now selected.

You can see the Sort Icon next to the fact name in the view
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See alsoWorking with Info-Explorer - Home Tab

VIEWING FACTS
Drag and drop the dimension you want visible from the facts list to the title bar

Page 50 of 124 Info-Explorer Analysis Tools



Info-Explorer

By dragging all the facts except amount due to the title bar, you will achieve :

FILTER A DIMENSION OR FACT
There are three ways to filter a dimension

filter using a tick box (on/off)
filter using a prefilter on the underlying dimension values
filter using calculated fact values

Filter using a tick box :
To filter a dimension, hover over the required dimension to activate that dimension and then click on the

small filter icon on the dimension title

and then selectively turn on or off the items required.
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If a dimension is already filtered, then the filter icon will always be visible. If a dimension is not already
filtered, then the filter icon will only be visible when you click on the dimension title.

Tip:
When you refresh the data, the filter can get reset if the selected value doesn't exist in the data and
new data are selected by default. You can use Pre-filter if you want the filter to be constant. See below.

Filter using a prefilter on the underlying dimension values :

Alternatively, click on Edit Prefilter on the Home Tab > View Ribbon to filter using a pre-
filter on the underlying dimension values, right hand mouse button on the dimension and select Show
Prefilter
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Build the filter string as required :

You can apply multiple conditions
The current filter shows at the bottom of the screen
The text filter is case sensitive
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Example:
In the example below, the filter is on both the Vendor dimension (Vendor Equals 1200) and
AmountDue fact.

To remove a filter, click the red x on the appropriate row.

If you remove AmountDue row, the view will show all transactions for Vendor = 1200.
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Filter using Calculated fact values
Alternatively, to filter using a filter applied to calculated values and totals, click on the Calculated values
filter on the required dimension .

and build the filter string as required. In this case the Facts you can select from are based on the visible
columns, and you can select “Any one” or “All” or “one specific” column. 

Info-Explorer Analysis Tools Page 55 of 124



Info-Explorer

Example:
Filter All vendors where for Every year, the Amount Due > 100 (not any one year or a specific year). As
with the prefilter, the current filter shows at the bottom of the screen and works in conjunction with
the prefilter (if any).

FILTER CALCULATED FACT VALUES DETAILS

The filter calculated fact values allows you to build filters on columns by row
data, or rows by column data.

Click on the red calculated values filter and build the filter string as required.

When selected on a row dimension, you can filter all the rows based on

The grand total being compared to your condition
Every column compared to your condition
At least one column compared to your condition
A specific column compared to your condition

You can apply multiple calculated fact filters, and are shown at the bottom of the Info-Explorer screen.
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To amend an existing filter, click on the blue hyperlink at the bottom of the screen, or click on the red "Fil-
ter" on the dimension.

Example:
In the following example:

NetSales > 500 for every year (calculated fact filter show in blue)

Cost > 600 for every year (calculated fact filter shown in blue)

To remove a filter, click the red x on the appropriate row
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FORMAT A CUBE - USING STYLES

RuLes for the Cube
To change the format (appearance) of a fact or all facts, click on the Edit button on the

Home tab>View Ribbon.

Create the styles required and apply the style to the cube by selecting "Rules for this cube" to change the
format for all facts.
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Example:
To create a style for totals with a blue background colour

and apply the style to the cube by selecting "Rules for this cube"

Info-Explorer Analysis Tools Page 59 of 124



Info-Explorer

Traffic Light Reporting Example
For Traffic light reporting, create 3 Styles for TrafficLightGreen, TrafficLightOrange and
TrafficLightRed and apply the new style to the required fact: 
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Set the rules for the field / fact: 

If less than 50, apply TrafficLightRed style
If between 50 and 60, apply TrafficLightOrange style
If greater than 60, apply TrafficLightGreen style
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To delete a style
If you have created a style in Info Explorer and you want to remove it for any reason, either it is not
required, or you may have a wrong spelling), press Delete key on keyboard to delete the selected style
from the cube.

Tip:
If the style is used in the Cube, Info Explorer will not allow it to be deleted and will display an error mes-
sage a message that the Style is in use and cannot be deleted.

Remove the style or replace with another style in the Rules for this cube or Rules for this field.

You can then delete it.
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FORMAT A FACT - CAPTION AND STYLES

Changing the caption
To change the caption of a fact, click on the Edit Fields button on the Home Tab
> View Ribbon

Select a Fact and change the caption. Click Save after changing
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Changing the Style
Change the style of any Fact (or the whole cube) click on the button on the Home Tab
> View Ribbon . First create the required style, and then apply it to the required fact.

For details, refer to Format a cube - Using Styles on page 58
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CREATE / AMEND /DELETE A FACT

To change the format (appearance) of a fact or create a fact, click on the Edit button

To Create a Fact
Select "Create New fact" on the fact list on the left hand side of the Fact/Formula edit window and fill in
the details as are required
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Assign the Fact a Name (for example MarginPC)
Assign the Fact a Caption (for example Margin %)

Value Field: Select the Aggregation type, such as SUM, AVERAGE, MINIMUM

Details of Aggregation Types:

Formula to define your own calculation in the Formula box (for example Margin % shown below
Sum - to total the fact defined in the "Of Field"
Number of records in "Of Field"
Minimum - to display the minimum of values in "Of Field"
Maximum - to display the maximum of values in "Of Field"
Average - to display the average of values in "Of Field"
Ascending Rank - to display the relative rank of values in "Of Field", lowest is 1
Descending Rank - to display the relative rank of values in "Of Field", highest is 1

In the Formula / Of Field options:

Formula : Type in the mathematical formula as required based on the facts retrieved by the query. Refer
to Formula Fact on page 81 for details
Of Field : Select the fact required. These are the numeric values retrieved by the query, not formulas
themselves.

Display as field, select the display type for the field selected

Default - to show as calculated

Absolute variation - shows the absolute variation of the current column against the
prior (visible) period

Percent variation - shows the percentage variation of the current column against the
prior (visible) period

Percent of column - to show the calculated field as a percentage of the column it is in (for
example Percent of Total shown below)

Percent of row - to show the calculated field as a percentage of the row it is in

Click Save to save changes made on the Fact/Formula editor

To Delete a Fact
Select the appropriate fact from the fact list on the left hand side of the Fact/Formula edit window
Click the Delete button.
Click Save after deleting.
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To Amend a Fact
Select the appropriate fact from the fact list on the left hand side of the Fact/Formula edit window
Change the caption of the Fact.
Change the Value of the field if required
Change the Display as of the field as required
Click Save after changing

Viewing Percent of column in a cube
In a sales analysis cube, you have a Net Sales fact and a customer dimension.

If you want to know how much each customer represents as the % of the total, you can do the following: 

Create a view in the cube with Customer as a Row dimension
Add Net Sales as a fact to the view
Add a Field to the cube, select Value = Sum, Of Field = Net Sales and Display As = Percent of
column
The new field now displays the % of the total column

If you change the row dimensions, for example, select Item instead of Customer, the % of column now
shows the percentage of each item.
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See AlsoWorking with Info-Explorer - Home Tab

FACTS VS DIMENSIONS IN A CUBE
Dimensions are the axes used to organise and categorise the data.

Facts are the data points you want to analyze. They are numeric and are aggregated using functions like
SUM, AVERAGE, COUNT, etc.

Refer to Create / Amend /Delete a fact on page 65 for details.

When Info-Explorer builds a cube from a SQL query, it assumes String columns in the queries will
become Dimensions and Numeric columns in the queries will become Facts.

Note:
Dimensions are displayed in black letters in the Available Fields Area.

Facts are displayed in blue letters.

You might want some numeric columns (Facts by default) to be a Dimension (for example Fiscal Period).
In this case you can edit the Field, and switch the type from "Fact" to "Dimension".
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Can Database String columns be a fact?
You might want some Dimensions (string columns) to be a Fact.

Info-Explorer only sees the database field type - which is a string. If you want the string column to be a
Fact, you will need to convert the string to a number in the SQL Query (using cast or convert).

This is only a valid option if the underlying values are always numeric.

Note: If the values are not numeric, you may need to use a different formula in the query, such as the
length of the string, and use this as a fact.

Example: In Sage 300, optional fields are always stored as Strings in the database, and the optional
field type tells Sage whether to display the field as a String, Date, Number or Boolean. You need to con-
vert the datatype in the SQL Query.

DRILL DOWN TO VIEW DETAILS.
Right click on any total value, and select Drilldown to view the underlying transactions and records
that make up the total.

The level of details depends on how the cube query is designed.

Click the Control button and “C” at the same time will copy the contents of the data grid to the clipboard.
You can then paste the details into another application if required for quick one-off analysis. 
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Tip:
When using Sage 300, you can also drill-through and open the underlying screens in the application.

Refer to Drill Through to Sage 300 screens below

DRILL THROUGH TO SAGE 300 SCREENS
To drill through to the relevant Sage 300 screen for a dimension value, right hand mouse button on the
value. If a "drill through" option is available, click to drill through to the appropriate Batch / Master file /
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Transaction in Sage 300.

Important! This feature is currently only available for Sage 300 classic desktop screens

For example, on the Batch Entry dimension below, drill through is enabled to the A/P Invoice Batch list-
ing:

The first time you click "drill through" during a session in the Info-Explorer, you will be prompted to con-
nect to a Sage 300 Company. This company will be the active drill down company until the next time the
Info-Explorer is opened.

Note: At the time of release of Info-Explorer 64-bit (May 2023), you need to log on to Sage 300 before
selecting the Drill-through option.
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Drill through options available
Drill through is configurable in the drilldown.ini file and / or in the Home Tab > Edit Fields to link Dimen-
sions to drill through configurations.

By default, Info Explorer is configured to drill through to :

I/C Item Number : Dimension label : ITEM, ITEMNO, FMTITEMNO 
A/R Customer Activity : Dimension label CUSTNO, IDCUST, CUSTOMER
*A/R Customer : Dimension label CUSTNO, IDCUST, CUSTOMER
A/P Vendor Activity : Dimension label : VENDNO,IDVEND,VENDOR
*A/P Vendor Number : Dimension Label : VENDNO,IDVEND,VENDOR
O/E Order Number : Dimension Label : ORDNUMBER
O/E Shipment Number : Dimension Label : SHINUMBER
O/E Invoice Number : Dimension Label : INVNUMBER
R/A RMA Number : Dimension Label : RMANUMBER
O/E Credit/Debit Note Number : Dimension Label : CRDNUMBER
P/O Requisition Number : Dimension Label : RQNNUMBER
P/O Purchase Order Number : Dimension Label : PONUMBER
P/O Purchase Receipt Number : Dimension Label : RCPNUMBER
P/O Purchase Invoice Number : Dimension Label : POINVNUMBER
P/O Purchase Return Number : Dimension Label : RETNUMBER
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P/O Purchase Credit/Debit Note Number : Dimension Label : CRNNUMBER
A/R Invoice Number : Dimension Label : ARIDINVC, ARDocumentNumber
A/P Invoice Number : Dimension Label : APIDINVC, APINVDC, APDocumentNumber
G/L Account Number : Dimension Label : GLACCOUNT,ACCOUNT,ACCTID
G/L Batch Entry : Dimension Label : BATCHENTRY

Tip: *If Drill down to customer and vendor (as opposed to Vendor Activity and Customer

Activity) is required, switch the two drill down groups in the drilldown.ini file

Advanced Analysis Tools (Home Tab)
The Home Tab includes more advanced functions, on the View Link: 

Working with Info-Explorer - Home Tab 74
Swap rows and columns 76
Collapse rows and columns (hierarchy) 77
Expand rows and columns (hierarchy) 79
Formula Fact 81
Amend a formula fact 82
Using Display Tab 84
Create a cube 87
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WORKING WITH INFO-EXPLORER - HOME TAB
Tip: You can either work with the full ribbon (as shown in first screenshot), or to maximise

the screen for data you can double click on the Home tab and work with a minimised rib-

bon as shown in the second screenshot.

Full Ribbon to view all the menu options: 

Minimised ribbon to maximise the data view

Tip: Double clicking on the Home tab again will maximise the ribbon

Home tab “quick links”
You can :

Open a cube

Create a new cube

Create a new tab

Connect to Sage 300 ERP

Refresh an existing cube

Refresh all or selected existing cubes

Close an existing cube
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Home tab “view” links
You can:

swap rows and columns of the active view

collapse rows and columns (hierarchy) of the active view

expand rows and columns (hierarchy) of the active view

Properties to View/Amend the cube’s properties and to set Auto Refresh

Query Builder to View/Amend the active cube’s query

Edit Fields to Create/Amend/Delete a fact

Edit Styles to change the appearance of a fact 

Edit Prefilter to create a Prefilter

Auto Calculate to view dimension changes immediately

Calculate to view dimension changes when clicked

Home tab “new” links
You can

Create a new dashboard

Create a new chart

Copy view

Home tab “export” links
Functionality not available with Info Explorer Lite.

You need to have a valid licence for Info-Explorer Standard or Writeback to: 

export the current slice to HTML

export the current slice to CSV
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export the current slice to MS Excel

SWAP ROWS AND COLUMNS

Swap row/column icon allows you to toggle the rows and columns. For example below, customer is
the rows and year the column. Clicking swap rows and columns you get year as the row and customer as
the column. 
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See alsoWorking with Info-Explorer - Home Tab

COLLAPSE ROWS AND COLUMNS (HIERARCHY)

Clicking the collapse hierarchy icon will automatically collapse all hierarchies for all dimensions as
the rows and columns.
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For Example, the Customers have been "collapsed" per customer group, and can be selectively "expan-
ded" by clicking on the + sign beside the vendor
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Clicking on the Expand rows and columns would expand all dimension elements.

See also Expand rows and columns

See alsoWorking with Info-Explorer

EXPAND ROWS AND COLUMNS (HIERARCHY)

Clicking the expand hierarchy icon will automatically expand all hierarchies for all dimensions as the
rows and columns.
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For example all customer groups and customers can be "expanded" by clicking the "expand rows and
columns" button, and can be selectively "collapsed" by clicking the - sign beside the required customer
group 

Clicking on the Expand rows and columns would expand all dimension elements.

See also Collapse rows and columns

See alsoWorking with Info-Explorer
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FORMULA FACT
If the query doesn't include the values you need, you can add calculations in a formula in the cube.

To create a formula fact, click on the Edit Fields Icon on the button on the Home Tab
> View Ribbon and choose the type of fact being "formula".

Type in the field name

Type in the field caption

Choose the value as "formula"
Type in the formula, using existing Factname.Value

Note: Fact names are case sensitive

Example: BUDGETSALES.VALUE-BUDGETCOST.VALUE for a budget margin calculation.

Select whether the totals are evaluated (recalculated based on the formula) or summed (the row/-
column is added not recalculated by formula)

Example: A % formula is generated evaluated, a margin calculation can be either.

Display as: use Default or Select how you would like the figure displayed (absolute/percent variation,
percent of column/row)

Note: Refer to Viewing Percent of column in a cube on page 67

Click Save
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Valid Operators & their relative priorities:

Operators Priority and Example
+ , - 8 (Highest) . Eg 10+2

gives 12 
^ 7 raise to the power. EG

2^4 gives16 
/, *, div, mod,
*%, /%

6

+, -, +%, -% 5
<, >, < =, > =,
==, !=

4. Comparisons return 1 if
true, 0 if false

not 3
and 2
or, xor 1
eqv 0 (Lowest)

AMEND A FORMULA FACT
To change a fact, click on the Edit Fields Button and make the change required
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See also Creating a Fact

See also Working with Info-Explorer

Auto-calculate

Click this icon to ensure that each time you drag & drop a dimension, the visible grid will re-
calculate. 

Deselect this option if you want to do a number of dimension changes, and re-calculate when all
the changes have been done. 

If the button is highlighted "gold” it is selected. 

If the button is not highlighted it is deselected. 

If Auto Calculate is deselected and changes have been made, the Calculate button is shown. Click it
to refresh the cube and view dimension changes.

See also Calculate

USING DISPLAY TAB
Use the Display Tab to show or hide totals, show or hide panels in Info-Explorer screen.

From the Display tab, you can control what Info-Explorer panels are displayed and how the information
is presented. :

Which titles are visible
Which totals are visible
If the entire view is scaled to the nearest one (1), ten (10), hundred (100) or thousand (1,000)
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Info-Explorer titles
For all options, when “Selected” or “on”, the option will be highlighted in orange, and the option will be
shown

.

When “De-Selected” or “off”, the option will not be highlighted and the option
will not be shown.

You can configure the following Title options: 

Show the Tree : shows or hides the list of views, charts and dashboards in the cube

Show the Available Fields area: this is the list of fields available to be added to a view and is determ-
ined by the cube query.

Show the Displayed Fields area: the fields currently included in the view

Show the Column titles:  This shows or hides the field names configured as columns in the view

Show the Row titles: This shows or hides the field names configured as rows in the view.

Display tab, “Totals” links
You can
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Show the Row Totals

Show the Row Grand Totals

Show the Column Totals

Show the Column Grand Totals

Display tab “scale” links
You can change the scale used to display the data

1x1 scale the data

This is the default selection and implies no scaling. For example 4,304.84 is displayed as 4,304.84

1x10 scale the data

To see your data rounded to 10's. For example, 4,304.84 is displayed as 430.48

1x100 scale the data

To see your data rounded to 100's. For example, 4,304.84 is displayed as 43.05

1x1,000 scale the data

To see your data rounded to 1000's. For example 4,304.84 is displayed as 4.30

Calculate

Click this icon to re-calculate the dimension and view changes made since Calculate was last
clicked. This icon is only shown when Auto Calculate is not selected.  

If the button is highlighted "gold” it is selected.

If the button is not highlighted it is not selected

See also Auto Calculate
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CREATE A CUBE
To create a new cube, click File>Create and follow the prompts to connect to a database and define the
required query.

Note, if you are using Info-Explorer Lite, then "create cube", "export to CSV" and "export to MS Excel" are
not available

Click Create Cube from the Home tab or File > Create to create a new cube

Select the required source :

From Database
Select an existing connection string or define a new connection string, and then build a query
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From Accpac (Sage 300),
Requirement! This is only available if using Optional Table module. It assumes that an Infoset exists in
Sage 300 > Information Manager > Optional Tables.

FROM ACCPAC DETAILS: 
Select a Sage 300 database, and then select the Infoset/Query and check the Database Connection
details from the Create Cube Screen
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Use the Query builder to assist in creating your query. Refer to Query Builder on page 106

See also Using Parameters in the query

See also

Using Charts and Dashboards
You can create Charts and Dashboards in the Home Ribbon > New links.

When the active view is a chart, use the Chart tab to format charts and change the chart type.

The Dashboard Tab is available when the active view is a Dashboard and lets you add and remove rows
and columns from a dashboard section in Info-Explorer.
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Create a dashboard 90
Using Dashboard Tab 92
Create a New Chart 93
Working with Info-Explorer – Chart Tab 96
Chart Properties 98

CREATE A DASHBOARD
You can create multiple dashboards in a cube to display separate views and charts in a single page.

If the cube has multiple queries, you can add views relating to the different queries in a single dash-
board.

To create a new dashboard :

Click Create dashboard icon on the Home Tab > New Ribbon or
Right Hand Mouse Button on a View or chart name and Select New dashboard

Amend size of views and charts
By default a New dashboard has 3 rows and 3 columns, allowing you to drag & drop 9 views or charts
from the current cube to the dashboard.

Use “Create Row” , “Create Column”, “Remove Row” and “Remove Column” to adjust the dashboard size
to have as many rows and columns as are required.  

Add and remove views and charts to dashboard
Drag and drop the required views & charts from the available cube to the dashboard.
Select the Close icon on the top right on any individual dashboard view or chart to deselect this
item.
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For example, the following dashboard has 2 rows, and 1 column
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USING DASHBOARD TAB
When the active view is a dashboard, the dashboard tab is visible

The Dashboard Tab lets you add and remove rows and columns from a dashboard section in Info-
Explorer.

Dashboard tab “quick links”
You can :

Add Row : add a row to the currently active dashboard 
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Remove Row : remove a row from the currently active dashboard 

Add Column: add a column to the currently active dashboard  

Remove Column: remove a column from the currently active dashboard  

CREATE A NEW CHART

Create a new chart by first selecting the View you want to base the chart on, and then

Clicking Create chart icon on the Home tab > New ribbon
Right Hand Mouse Button on the selected View and selecting New Chart, or Click New Chart on
the Home Tab > New Ribbon.
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From the New Chart window, you can select the File menu and :
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Save the new chart

Save as the new chart to assign a name and add the chart to the cube file

Change the Chart Type to one of Line, Bar or Pie

Swap the Chart axis (i.e. swap the x and y axes)

Selectively show the Chart Labels

Change the Chart Properties

Close the chart

From the New Chart window, you can select the Legend menu and select where the legend is to show 

From the New Chart window, you can select the Data points menu and select what data points are to
show 
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WORKING WITH INFO-EXPLORER – CHART TAB
When the active view is a chart, the Chart tab is visible

Chart tab “quick links” :

Save : to save the current chart

Save as: to save the current chart to a new name

Properties : to review the chart properties 

Swap Axis : to swap the x and y axis of the current line chart

From the Chart tab “style” links
You can change the current chart style to : 

Line : to select a Line Chart  

Bar : to select a Bar Chart 
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Pie : to select a Bar Chart 

Chart tab “Labels” links
You can selectively show labels : 

Left : to select a left or x axis labels 

Bottom: to select a bottom or y axis labels 

Chart tab “Legend ” links
you can change the legend position on the currently active chart: 

None: to have no chart legend 

Left: to the chart legend on the left 

Right: to the chart legend on the right   

Top: to the chart legend on the top 

Bottom: to the chart legend on the bottom 

Chart tab “Data points ” links
you can selectively show symbols for the data points on a line chart : 

None: no symbol for data points shown

Square: square symbol for data points shown

Circle: square symbol for data points shown 

Diamond: diamond symbol for data points shown

Triangle up: triangle up symbol for data points shown
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Triangle down: triangle down symbol for data points shown 

Cross: cross symbol for data points shown 

Plus: plus symbol for data points shown

Star: star symbol for data points shown 

Vertical Dash: vertical dash symbol for data points shown

Horizontal Dash: horizontal dash symbol for data points shown 

CHART PROPERTIES
Chart Properties allows you to

Change the Chart Type
Change the background colour
Change legend positions
Show/hide data points and select the data point shape
Swap the axis
Select the values to be shown
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Export Overview
Using Info-Explorer with a Full or Writeback licence, you can export cube views.

Export to CSV 100
Export to HTML 100
Export to MS Excel 101
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Warning! If you are using Info-Explorer Lite, then "create cube", "export to CSV",

"export to HTML" and "export to Excel" are not available.

EXPORT TO CSV

Warning! If you are using Info-Explorer Lite, then "create cube", "export to CSV", "export

to HTML" and "export to Excel" are not available.

To export the current slice to a CSV (comma separated values) file, click the Export to CSV icon and
provide the appropriate file path and file name.

See AlsoWorking with Info-Explorer - Home Tab

EXPORT TO HTML
Note, if you are using Info-Explorer Lite, then "create cube", "export to CSV", "export to HTML" and "export to Excel"
are not available
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To export the current slice to a HTML file, click the Export to HTML icon and provide the appropriate file
path and file name.

See AlsoWorking with Info-Explorer - Home Tab

EXPORT TO MS EXCEL
Requirement!
if you are using Info-Explorer Lite, then "create cube", "export to CSV", "export to HTML" , "export to
MS Excel" and "Worksets" are not available.

Worksets and Writeback are only available if the Info Explorer - Write back licence has been purchased
and activated. If you are using "info-Explorer - Full", then "Worksets" and Writeback are not available.

To export the current slice to a MS Excel file, click the Export to MS Excel icon or the Home Tab > Export
Ribbon and provide the appropriate file path and file name
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Properties: Security, Connections and Parameters
Clicking Properties on the Home Ribbon will allow you to define and change the existing properties

of the cube.

Use the Options > Lock buttons to set passwords on selected functions in Info-Explorer.

SECURITY OPTIONS FOR THE CUBE.
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You can set a password for the following function in Info-Explorer. Users are prompted to enter the pass-
word before they can change the cube configuration or run the locked process, such as Refreshing the
cube.

REMOVE THE LOCK
To remove the lock, enter the Old Password and leave the password blank (for New and Confirm).

Tip: There is no master password. If you don't remember the password, the file may become unusable.
We suggest to save a copy of the unprotected file in a secure folder that only Admin users have access
to. You need to enter the existing

WHEN TO USE LOCK OPTIONS
Lock File: Users need a password to open an entire .cubx file
Lock Connections: Users need to enter the password to view/change the connection parameters.
This is useful to ensure users cannot change the database that the cube is pointing to.
Lock Cubes: Users need to enter the password before viewing or amending the query. This is rel-
evant when you want to restrict what tables/entities are included in the cube.
Lock Refresh: Users need to enter the password to refresh the cube. This is often used for large
cubes and in conjunction with using automated processes to refresh the cubes outside of business
hours.
Lock Writeback: Users need a password to write to the ERP Application database and update the
budget/forecast data with the currently selected Workset. 
Lock Writeback Query: Users need a password to change the query being used and therefore the
data being updated in the ERP Application when using the Writeback function.

PARAMETERS :
Define parameters and default values when running queries. See Using Parameters in a query
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CONNECTIONS :
Define the database connections for each query.

See Create a new connection

See Configure to a different database

CUBES:
For background, refer to Amend cube query on the facing page

Click on the cube name (or “new cube” if the cube has not been renamed), and you will be able to

• Review and change the connection for this query

• Review and amend the SQL query for the cube

• Click on Query Builder to use the Query Builder to amend the SQL Query. See Query Builder

Tip: If there is an error when running the query, you can press CTRL + C to copy the query and error
content to SQL Management Studio or Notepad.

Select "Refresh Automatically on open" to refresh the data when opening the file.

+Views
Expand the + beside Views under each cube and you will see all the views defined on the current query.

+Write back
Expand the + beside Writeback to see all the facts in the current cube. By clicking on any one of the facts
you will be able to define a SQL query to write the selected fact back from a workset to the underlying
ERP database. See Writeback

Requirement! Please note: Write Back is not standard feature and requires a separate licence.

The total number of records in the cube will be displayed.

The current key defined for the networks will be displayed (the relevant dimensions will be in bold).

To view the records, click “view records”

To define the key dimensions, click “Define Key Fields”. See Define Key Fields

AUTO REFRESH:
Enter the number of minutes after which the currently active cube view will refresh.

If zero, then the cube will not auto refresh. The “count down” clock on the top right hand side of the rib-
bon will show when the cube will next refresh.
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See Also Working with Info-Explorer – Home Tab

AMEND CUBE QUERY
You can amend the cube query to add / remove fields from database tables or calculated fields to the
cube. There two methods: 

Using Query Builder:
The "Query Builder" generates a diagrammatic representation of your SQL query, showing the things
that provide your cube with Dimensions (things to analyse data by) and Facts (the data to analyse). E.g.
the relevant tables with their associated joins, the selected fields, and any formatting and calculations
applied to those fields.

Refer to Query Builder on the next page

Updating the cube Properties
You can also update the cube queries without using Query Builder.

For example, if you are converting an existing report with a query that you want to use in Info-Explorer or
in cases where the query is too complex to represent diagrammatically in Query Builder.

If you want to amend the query (or queries) in your cube without using the in-built Query Builder

1. Click on Properties
2. Click on the required Query in the "Cube" node, .e.g. "New cube".
3. Amend the query and/or copy and paste from SQL Management Studio
4. Click OK
5. Click to save your cube

Note: If you have multiple queries, you will have multiple entries under the node "Cube". You need to
select each query one at a time.
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Viewing query error
If there is an error when refreshing the cube, the error message is displayed. In some cases, the error mes-
sage may be truncated.

To see the full error, please try using CTRL-C when on the error message and CTRL-V to paste into Note-
pad or other editor.

QUERY BUILDER
Click this icon to view and amend the existing query for the active cube.

Overview
The "Query Builder" generates a diagrammatic representation of your SQL query, showing the things
that provide your cube with Dimensions (things to analyse data by) and Facts (the data to analyse). E.g.
the relevant tables with their associated joins, the selected fields, and any formatting and calculations
applied to those fields.

If the connections between the tables aren’t too many or too complex, the selected tables and joins will
be shown in the Query Builder. You can "visually" link/join the tables by selecting the relevant field from
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one table and dragging the link to the other table/field, then selecting fields from tables to be added
into the SQL Query for Info-Explorer.

How to use
Use the Query builder to assist in creating your query. Here you can :

Double click on the table name to add the table to your query
Select the columns required by clicking on the tick box to the left of the column name or type the
column name in the expression box
Type in the aggregate function (if required)
Type in an Alias (if required)
Select Sort Type and Sort Order and Group by if required
Test the query by clicking on the data tab to view the results
To join tables, click on the column in the first table and drag to the second table. The join type can
be amended by double clicking on the line joining the tables
Type in functions (for example Rtrim) in the Expressions window
When complete, click File > OK and the new cube will be created in the workbook
The SQL query can also be typed and amended in the SQL Pane
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Troubleshooting
When using the Query Builder in Orchid Info-Explorer the following error message may be displayed:
'Invalid SELECT Statement. Unexpected token "%" at line x'.

Info-Explorer will still be able to execute the SQL Query and display the result, as long as the syntax of
the SQL Query is correct.

What causes the error?

The error occurs if the SQL Query has too many tables, and/or the syntax of the query is too complex, for
the Query Builder to generate a diagrammatic representation of the query.

Typical examples occur when the query includes an Info-Explorer parameter, or when using the CAST
function in SQL.
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Solution: Amend the query in the Cube > Properties

If you receive this error message, you won’t be able to make changes to the SQL Query ‘visually’ using
the Query Builder. Instead, any changes will have to be done directly by editing the SQL Query box in the
Properties of the cube.

If you want to amend the query (or queries) in your cube without using the in-built Query Builder

1. Click on Properties
2. Click on the required Query in the "Cube" node, .e.g. "New cube".
3. Amend the query and/or copy and paste from SQL Management Studio
4. Click OK
5. Click to save your cube

Note: If you have multiple queries, you will have multiple entries under the node "Cube". You need to
select each query one at a time.

See also Using Parameters in the query

See alsoWorking with Info-Explorer – Home Tab

DEFINE KEY FIELDS
All the dimensions from the current cube will be displayed. Select those dimensions which make up the
key to each of the budget records. This is only required if you need to refresh the cube (to get up-to-
date actual figures) in a cube where you already have a workset (or networks defined) which are based
on the actuals, but you do not want to lose the budget, forecast or scenario data already entered.

See alsoWorking with Info-Explorer – Home Tab

USING PARAMETERS IN THE QUERY

After building the query (or pasting in the query from another query builder tool), you can add para-
meters which can restrict the data to be viewed. The parameters can either be visible/amendable by the
users when "refresh" is clicked, or hidden. 

To add a new parameter, click on the Properties icon

Click "Add Parameter" to add a new parameter, or click the existing parameter to amend an existing para-
meter :
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Per parameter you can define:

The parameter Name
The parameter Label
The parameter tool tip description
an optional default value
set if it is a hidden parameter
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After defining the parameters, these must be edited into the query as is required - between % symbols.
For example "FROMFISCALYEAR" and :TOFISCALYEAR" as shown in red below : 

SELECT rtrim(A.ACCTSEGVAL)+' - '+rtrim(A.ACCTDESC) AS Account, rtrim(A.ACSEGVAL02)+' - '+rtrim
(S1.SEGVALDESC) AS SEGMENT1, rtrim(A.ACSEGVAL03)+' - '+rtrim(S2.SEGVALDESC) AS SEGMENT2, rtrim
(A.ACSEGVAL04)+' - '+rtrim(S3.SEGVALDESC) AS SEGMENT3, rtrim(A.ACCTGRPSCD)+' - '+rtrim(GRP.ACCTGRPDES)
AS AccountGroup, CASE rtrim(A.ACCTTYPE) WHEN 'B' THEN 'Balance Sheet' ELSE 'Income Statement' END AS
AccountType, F.FSCSYR, '01' AS Period, (case when F.FSCSDSG = 'A' then (F.OPENBAL + F.NETPERD1) else 0 end) AS
Actual,

(case when F.FSCSDSG = '1' then (F.OPENBAL + F.NETPERD1) else 0 end) AS Budget1 

FROM GLAMF AS A LEFT OUTER JOIN GLASV AS S1 ON A.ACSEGVAL02 = S1.SEGVAL AND S1.IDSEG =
'000002'

LEFT OUTER JOIN GLASV AS S2 ON A.ACSEGVAL03 = S2.SEGVAL AND S2.IDSEG = '000003'

LEFT OUTER JOIN GLASV AS S3 ON A.ACSEGVAL04 = S3.SEGVAL AND S3.IDSEG = '000004'

LEFT OUTER JOIN GLACGRP AS GRP ON A.ACCTGRPSCD = GRP.ACCTGRPCOD
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LEFT OUTER JOIN GLAFS AS F ON A.ACCTID = F.ACCTID AND F.CURNTYPE = 'F' and FSCSYR >=
%FROMFISCALYEAR% and FSCSYR <= %TOFISCALYEAR%

See also Creating a cube

See alsoWorking with Info-Explorer - Home Tab

CREATE A NEW CONNECTION
To create a new database connection, select Properties on the Home Tab.

Then select the "Connections" option. Then Click "Add Connection" and specify the connection details. 

Tip: You can use this if you need to switch the cube between different databases (a test and live data-
bases). It is also useful if you include data from different databases in the same cube file (cubx exten-
sion).
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The different database driver details that can be selected are :

IBM DB2
Microsoft SQL Server
Oracle
Pervasive.SQL
ODBC
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AUTO REFRESH

Configure Auto-Refresh while using the cube: 
On the Home Ribbon, select Properties > Auto Refresh and select how often you want to refresh the data
(in minutes).

Configure Refresh on Opening the cube -
On the Home > Properties > Cubes > Select a cube.

Select the cube name, for example \New Cube

Tick "Refresh Automatically on open"

This will refresh the data in the cube when you open it.
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For other Options, refer to Refresh Info-Explorer Cubes on page 40

Info-Explorer Writeback
Info-Explorer Writeback allows you to budget beyond the G/L Level and use various spread methods to
populate the budget top-down or bottom up.

Multiple Spread Methods
Update budget data through Analysis Interface
Writeback to Sage 300 or other databases
Maintain multiple budget versions

Using Info-Explorer Writeback with Optional Tables 116
Budgeting using the Workset Tab 117
Writeback to Sage 300 119

Refer to Info-Explorer Writeback training video
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USING INFO-EXPLORER WRITEBACK WITH OPTIONAL
TABLES
The first example describes Sage 300 budgeting at the GL level using Info-Explorer (with Budget Write-
back) and Optional Tables (with Excel Add-in).

The second example describes Sage 300 budgeting at the GL & Transactional Optional Field level (e.g.
Project Budgeting) using Info-Explorer and Optional Tables.
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The third example describes Sage 300 budgeting at the Sub-ledger level (e.g. Customer & Item budget-
ing) using Info-Explorer and Optional Tables.

BUDGETING USING THE WORKSET TAB
Requirement! You need a “Budget and Writeback” licence to view the Workset tab.
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From the Workset tab, "Workset” links you can

Create a new Workset

Delete and existing Workset

Copy an existing Workset

Rename a Worksheet

Write back a workset to underlying ERP

To amend a budget, forecast or scenario figure, double click on the cell and change the value.

Note:
If this cell is made up of a single record, then the single value will be updated.

If the cell you have changed is a total of a number of records, then the total will be amended by updat-
ing the underlying records. The underlying records will be updated according to the selected “Spread”
method.

Spread methods
Evenly : The total value entered is divided by the number of records making up the total,
and this equal value is spread to all he underlying records
Proportionally : When this method is selected, you need to specify which values are to
form the basis of the spread – the current value in the Workset, or the original value of the
workset before any changes were made. Additionally you can spread proportionally based on a
different dimension value.
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Example:
In the example below, any changes to the budget figure will be spread based on the existing
current values in the “Actual” version.

Minimum only : The total value entered is assigned to the single record which has the
minimum value of the underlying records
Maximum only: The total value entered is assigned to the single record which has the
maximum value of the underlying records
Average : The value entered is the average value, and will be assigned to all records
making up the total.
Percentage increase/decrease: The total percentage value entered is applied to
all the records making up the total.

Example: To increase all records by 10%, enter “10”. To decrease all records by 10%, enter “-
10”.

Absolute increase/decrease: The absolute value entered is applied to all the
records making up the total.

Example: To increase all records by $100, enter “100”. To decrease all records by $100, enter
“-100”.

WRITEBACK TO SAGE 300

Warning! With a “Budget and Writeback” licence, you are able to view the Workset tab

and use the Writeback functionality.

Once the required fact has been selected, the SQL query to be executed for each amended fact will be
displayed.

The SQL query will be executed for all amended facts. You can include dimension values from your cube
by including them in the SQL statement, surrounded by percent signs (%).

The amended budget, forecast or scenario figures must be included from your cube by including the fact
as %VALUE%

There are 3 supported write back queries for Sage 300
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1. GL Budgets
2. Information Manager Infosets
3. IC Item Projected Sales

Note:
No new records will be created in the Sage 300 database with the default queries.

to update a GL budget for an account/fiscal year/fiscal period combination – the budget

record must already exist in Sage 300. So you might need to import zero for all account-

s/fiscal year/fiscal periods required.

to update an information manager infoset, the initial record must be inserted for the key

combination and date required. So you might need to use an import/export into Infosets, or

the Information Manager Excel add-in to create new records

to update IC Item projected sales, the initial record(s) must be imported into the IC reorder

table

Example SQL queries:
1. Example SQL query to update GL Budgets:

For a specific site, the sample cube would need adapting.
Included dimensions included in percentage signs %xxx%, and are highlighted in yellow
The budget, forecast or scenario data entered is always called %VALUE% shown in green below
The SQL query is shown in blue text below
Hard coded fields in red (currency, budget set and currency type) would need amending per cus-
tomer site
DECLARE @SQL VARCHAR(MAX);
DECLARE @columnname VARCHAR(10);
DECLARE @period VARCHAR(2);
DECLARE @currency VARCHAR(3);
DECLARE @fscdsg VARCHAR(1);
DECLARE @curntype VARCHAR(1);
SET @currency = N'CAD';
SET @fscdsg = N'1';
SET @curntype = N'F';
SET @period = N'%PERIOD%';
SET @columnname = N'NETPERD' +
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case left(@period,1) when '0' then RIGHT(rtrim(@period),1) else RIGHT(rtrim(@period),2) end;
SET @SQL = 'UPDATE GLAFS set ' + @columnname + ' = %VALUE% WHERE RTRIM(ACCTID) =
''%UNFORMATTEDACCOUNT%'' AND FSCSYR = ''%FISCALYEAR%'' AND FSCSCURN = ''' + @cur-
rency +
''' AND FSCSDSG = ''' + @fscdsg + ''' AND CURNTYPE = ''' + @curntype + ''';'
EXEC (@SQL);

2. Example SQL query to update Customer/Item Budgets:

This query is designed to update a Customer/Item budget stored in an Information Manager
infoset. There are facts which can be entered, Budget Quantity, Budget Sales and Budget Cost

Included dimensions included in percentage signs %xxx%, and are highlighted in yellow
The budget, forecast or scenario data entered is always called %VALUE% shown in green below
The SQL query is shown in blue text below
Hard coded variables which might require changing per customer site are shown in red text below

a. SQL Query for fact BUDQTY

SQL Query for BUDQTY
DECLARE @SQL VARCHAR(MAX);
DECLARE @infokey as VARCHAR(10) = CONVERT(VARCHAR(10),'%INFOKEY%');
DECLARE @optfield as VARCHAR(10) = N'BUDQTY';
SET @SQL = 'UPDATE EBINFOO set VALUE = %VALUE% WHERE INFOKEY = ' + @infokey +' AND RTRIM
(OPTFIELD) = ''' + @optfield +  ''' ;' ;
EXEC (@SQL);

b. SQL Query for fact BUDCOST

DECLARE @SQL VARCHAR(MAX);
DECLARE @infokey as VARCHAR(10) = CONVERT(VARCHAR(10),'%INFOKEY%');
DECLARE @optfield as VARCHAR(10) = N'BUDCOST';
SET @SQL = 'UPDATE EBINFOO set VALUE = %VALUE% WHERE INFOKEY = ' + @infokey +
' AND RTRIM(OPTFIELD) = ''' + @optfield + ''' ;' ;
EXEC (@SQL);

c. SQL Query for fact BUDVALUE

DECLARE @SQL VARCHAR(MAX);
DECLARE @infokey as VARCHAR(10) = CONVERT(VARCHAR(10),'%INFOKEY%');
DECLARE @optfield as VARCHAR(10) = N'BUDCOST';
SET @SQL = 'UPDATE EBINFOO set VALUE = %VALUE% WHERE INFOKEY = ' + @infokey +
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' AND RTRIM(OPTFIELD) = ''' + @optfield + ''' ;' ;
EXEC (@SQL);

3. Example SQL query to update IC Item Projected Sales Budgets:
This query is designed to update a Customer/Item budget stored in an Information Manager
infoset. There are facts which can be entered, Budget Quantity, Budget Sales and Budget Cost

Included dimensions included in percentage signs %xxx%, and are highlighted in yellow
The budget, forecast or scenario data entered is always called %VALUE% shown in green below
The SQL query is shown in blue text below
DECLARE @SQL VARCHAR(MAX);
DECLARE @periodstart as VARCHAR(8) = CONVERT(VARCHAR(9),'%PERIODSTART%',112);
DECLARE @itemno as VARCHAR(24) = N'%ITEMNO%';
DECLARE @location as VARCHAR(10) = N'%LOCATION%';
SET @SQL = 'UPDATE ICREORD set SALESPROJ = %VALUE% WHERE RTRIM(ITEMNO) = ''' +
@itemno +
''' AND LOCATION = ''' + @location + ''' and PERIODSTRT = ' + @periodstart + ' ;' ;
EXEC (@SQL);
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